Re: [PATCH v2] ACPI: use sysfs_emit() to instead of scnprintf()

From: Rafael J. Wysocki
Date: Fri Dec 02 2022 - 14:26:27 EST


On Wed, Nov 30, 2022 at 9:16 AM <ye.xingchen@xxxxxxxxxx> wrote:
>
> From: ye xingchen <ye.xingchen@xxxxxxxxxx>
>
> Replace the open-code with sysfs_emit() to simplify the code.
>
> Signed-off-by: ye xingchen <ye.xingchen@xxxxxxxxxx>
> ---
> v1 -> v2
> combine patchs in drivers/acpi/.
> drivers/acpi/acpi_pad.c | 4 ++--
> drivers/acpi/cppc_acpi.c | 4 ++--
> 2 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/acpi/acpi_pad.c b/drivers/acpi/acpi_pad.c
> index edbb28faee2a..02f1a1b1143c 100644
> --- a/drivers/acpi/acpi_pad.c
> +++ b/drivers/acpi/acpi_pad.c
> @@ -287,7 +287,7 @@ static ssize_t rrtime_store(struct device *dev,
> static ssize_t rrtime_show(struct device *dev,
> struct device_attribute *attr, char *buf)
> {
> - return scnprintf(buf, PAGE_SIZE, "%d\n", round_robin_time);
> + return sysfs_emit(buf, "%d\n", round_robin_time);
> }
> static DEVICE_ATTR_RW(rrtime);
>
> @@ -309,7 +309,7 @@ static ssize_t idlepct_store(struct device *dev,
> static ssize_t idlepct_show(struct device *dev,
> struct device_attribute *attr, char *buf)
> {
> - return scnprintf(buf, PAGE_SIZE, "%d\n", idle_pct);
> + return sysfs_emit(buf, "%d\n", idle_pct);
> }
> static DEVICE_ATTR_RW(idlepct);
>
> diff --git a/drivers/acpi/cppc_acpi.c b/drivers/acpi/cppc_acpi.c
> index 093675b1a1ff..0f17b1c32718 100644
> --- a/drivers/acpi/cppc_acpi.c
> +++ b/drivers/acpi/cppc_acpi.c
> @@ -148,7 +148,7 @@ __ATTR(_name, 0444, show_##_name, NULL)
> if (ret) \
> return ret; \
> \
> - return scnprintf(buf, PAGE_SIZE, "%llu\n", \
> + return sysfs_emit(buf, "%llu\n", \
> (u64)st_name.member_name); \
> } \
> define_one_cppc_ro(member_name)
> @@ -174,7 +174,7 @@ static ssize_t show_feedback_ctrs(struct kobject *kobj,
> if (ret)
> return ret;
>
> - return scnprintf(buf, PAGE_SIZE, "ref:%llu del:%llu\n",
> + return sysfs_emit(buf, "ref:%llu del:%llu\n",
> fb_ctrs.reference, fb_ctrs.delivered);
> }
> define_one_cppc_ro(feedback_ctrs);
> --

Applied as 6.2 material, thanks!