Re: [PATCH v2 4/6] pwm: lpss: Allow other drivers to enable PWM LPSS

From: Andy Shevchenko
Date: Fri Nov 11 2022 - 08:50:59 EST


On Thu, Nov 10, 2022 at 11:23:17AM +0100, Uwe Kleine-König wrote:
> On Thu, Nov 10, 2022 at 11:58:53AM +0200, Andy Shevchenko wrote:
> > On Thu, Nov 10, 2022 at 9:28 AM Uwe Kleine-König
> > <u.kleine-koenig@xxxxxxxxxxxxxx> wrote:
> > > On Tue, Nov 08, 2022 at 04:22:24PM +0200, Andy Shevchenko wrote:
> > > > The PWM LPSS device can be embedded in another device.
> > > > In order to enable it, allow that drivers to probe
> > > > a corresponding device.

...

> > > Now that pwm_lpss_boardinfo lives in a different file, this makes the
> > > move of pwm_lpss_chip in patch 3 somewhat redundant.
> >
> > But they are independent changes. At each stage (after each patch) we
> > should have a finished step, right? Not touching that makes me feel
> > that the step is half-baked. If you insist I can drop that move from
> > the other patch.
>
> Given that the move is something you do just en passant in the earlier
> patch , I consider my suggestion cleaner. I'd call that 0.5 * insist.

I have looked again and I have noticed that in the current state we have

sturct pwm_lpss_chip {
...
};

struct pwm_lpss_boardinfo {
...
};

extern struct pwm_lpss_boardinfo ...;


In the proposed change (with move included) it becomes

#include <...>

extern struct pwm_lpss_boardinfo ...;

sturct pwm_lpss_chip {
...
};

and without

#include <...>

sturct pwm_lpss_chip {
...
};

extern struct pwm_lpss_boardinfo ...;

And I consider that my way is slightly better in terms of ordering.
That said, I will leave it as is for v3. We may continue discussing
it further there.

--
With Best Regards,
Andy Shevchenko