Re: [RFC PATCH 03/23] sched/core: Initialize the class of a new task

From: Peter Zijlstra
Date: Tue Sep 27 2022 - 09:05:06 EST


On Mon, Sep 26, 2022 at 02:57:29PM +0000, Joel Fernandes wrote:

> > +#ifdef CONFIG_SCHED_TASK_CLASSES
> > + p->class = TASK_CLASS_UNCLASSIFIED;
> > +#endif
>
> I find the term 'class' very broad and unclear what kind of class (without
> further reading). So I am worried about how this generic term usage plays
> with Linux source code in the long-term (like what if someone else comes up
> with a usage of term 'class' that is unrelated to IPC.)

However much I like making a pain for people using C++ to compile the
kernel, I do think ipcc might be better here
(instructions_per_cycle_class for those of the novel per identifier
school of thought).

> To that end, I was wondering if it could be renamed to p->ipc_class, and
> CONFIG_SCHED_TASK_IPC_CLASSES, or something.

Can we *please* shorten those thing instead of writing a novel?
CONFIG_SCHED_IPC_CLASS works just as well, no? Or TASK_IPC, whatever.