Re: [PATCH v5 01/20] dt-bindings: imx6q-pcie: Fix clock names for imx6sx and imx8mq

From: Serge Semin
Date: Thu Aug 25 2022 - 09:01:17 EST


Hi Alexander,

On Thu, Aug 25, 2022 at 09:55:56AM +0200, Alexander Stein wrote:
> Hello Serge,
>
> Am Montag, 22. August 2022, 20:46:42 CEST schrieb Serge Semin:
> > Originally as it was defined the legacy bindings the pcie_inbound_axi and
> > pcie_aux clock names were supposed to be used in the fsl,imx6sx-pcie and
> > fsl,imx8mq-pcie devices respectively. But the bindings conversion has been
> > incorrectly so now the fourth clock name is defined as "pcie_inbound_axi
> > for imx6sx-pcie, pcie_aux for imx8mq-pcie", which is completely wrong.
> > Let's fix that by conditionally apply the clock-names constraints based on
> > the compatible string content.
> >
> > Fixes: 751ca492f131 ("dt-bindings: PCI: imx6: convert the imx pcie
> > controller to dtschema")
> > Signed-off-by: Serge Semin
> > <Sergey.Semin@xxxxxxxxxxxxxxxxxxxx>
> >
> > ---
> >
> > Changelog v5:
> > - This is a new patch added on the v5 release of the patchset.
> > ---
> > .../bindings/pci/fsl,imx6q-pcie.yaml | 47 +++++++++++++++++--
> > 1 file changed, 42 insertions(+), 5 deletions(-)
> >
> > diff --git a/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
> > b/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml index
> > 376e739bcad4..ebfe75f1576e 100644
> > --- a/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
> > +++ b/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
> > @@ -16,6 +16,47 @@ description: |+
> >
> > allOf:
> > - $ref: /schemas/pci/snps,dw-pcie.yaml#
> > + - if:
> > + properties:
> > + compatible:
> > + contains:
> > + const: fsl,imx6sx-pcie
> > + then:
> > + properties:
> > + clock-names:
> > + items:
> > + - const: pcie
> > + - const: pcie_bus
> > + - const: pcie_phy
> > + - const: pcie_inbound_axi
> > + - if:
> > + properties:
> > + compatible:
> > + contains:
> > + const: fsl,imx8mq-pcie
> > + then:
> > + properties:
> > + clock-names:
> > + items:
> > + - const: pcie
> > + - const: pcie_bus
> > + - const: pcie_phy
> > + - const: pcie_aux
> > + - if:
> > + properties:
> > + compatible:
> > + not:
> > + contains:
> > + enum:
> > + - fsl,imx6sx-pcie
> > + - fsl,imx8mq-pcie
>
> I'm not so sure about this list essentially copying the (for now) two
> compatibles from above, but no hard from my side. I have a quite similar patch
> nesting the following structure:

> if imx6sx
> then
> <4 clocks including pcie_inbound_axi>
> else if imx8mq
> then
> <4 clocks including pcie_aux>
> else
> <3 clocks>

The schema above looks a bit different in your case:
+ if:
+ then:
+ else:
+ if:
+ then:
+ else:

Anyway the main point is each new statement adds one more indentation
level, which in case of updating the schema with new clocks setup will
get to be even more right shifted. Note for that reason you'd need to
fully update the last else block. So the corresponding patch will get
to be bulky and less readable.

Another point for my approach is that the if-else-if-else-etc
statement much harder to read than just multiple if-statements
combined in the allOf property.

IMO that's why more often you get to see the allOf-if-if-etc pattern than
the allOf-if-else-if-else one.

>
> In the end I'm fine with both approaches, whatever DT bindings maintainer find
> superior.
> Acked-by: Alexander Stein <alexander.stein@xxxxxxxxxxxxxxx>

Thanks.

-Sergey

>
>
> > + then:
> > + properties:
> > + clock-names:
> > + items:
> > + - const: pcie
> > + - const: pcie_bus
> > + - const: pcie_phy
> >
> > properties:
> > compatible:
> > @@ -57,11 +98,7 @@ properties:
> >
> > clock-names:
> > minItems: 3
> > - items:
> > - - const: pcie
> > - - const: pcie_bus
> > - - const: pcie_phy
> > - - const: pcie_inbound_axi for imx6sx-pcie, pcie_aux for imx8mq-pcie
> > + maxItems: 4
> >
> > num-lanes:
> > const: 1
>
>
>
>