Re: [PATCH] iio: Avoid multiple line dereference for mask

From: Jonathan Cameron
Date: Fri Aug 19 2022 - 13:44:30 EST


On Thu, 18 Aug 2022 20:08:27 -0400
Joe Perches <joe@xxxxxxxxxxx> wrote:

> On Thu, 2022-08-18 at 08:58 -0400, Joe Simmons-Talbott wrote:
> > Add a mask variable to hold dereferences that span multiple lines.
> > Found with checkpatch.pl.
> []
> > diff --git a/drivers/iio/industrialio-core.c b/drivers/iio/industrialio-core.c
> []
> > @@ -1301,10 +1302,9 @@ static int iio_device_add_channel_sysfs(struct iio_dev *indio_dev,
> > return ret;
> > attrcount += ret;
> >
> > + mask = &chan->info_mask_separate_available;
> > ret = iio_device_add_info_mask_type_avail(indio_dev, chan,
> > - IIO_SEPARATE,
> > - &chan->
> > - info_mask_separate_available);
> > + IIO_SEPARATE, mask);
>
> The issue is the conflict between using 30+ character identifiers and 80 column lines.
> Perhaps it's better just to use a longer line instead of a temporary.
>
> ret = iio_device_add_info_mask_type_avail(indio_dev, chan, IIO_SEPARATE,
> &chan->info_mask_separate_available);

Agreed. Looks nicer to me this way and still under the wider 100 char limit
which is appropriate when readability is improved.

Some unfortunately long identifiers, that I think got there via evolution.
We should consider shortening them that's a job for a separate patch.


> []
>
> > @@ -1316,10 +1316,9 @@ static int iio_device_add_channel_sysfs(struct iio_dev *indio_dev,
> > return ret;
> > attrcount += ret;
> >
> > + mask = &chan->info_mask_shared_by_type_available;
> > ret = iio_device_add_info_mask_type_avail(indio_dev, chan,
> > - IIO_SHARED_BY_TYPE,
> > - &chan->
> > - info_mask_shared_by_type_available);
> > + IIO_SHARED_BY_TYPE, mask);
>
> ret = iio_device_add_info_mask_type_avail(indio_dev, chan, IIO_SHARED_BY_TYPE,
> &chan->info_mask_shared_by_type_available);
>
> etc...
>
>