[RFC PATCH 0/4] riscv: Add basic percpu operations

From: guoren
Date: Mon Aug 08 2022 - 04:06:19 EST


From: Guo Ren <guoren@xxxxxxxxxxxxxxxxx>

The series try to add basic percpu operations for riscv. HAVE_CMPXCHG_LOCAL
would let people confuse with cmpxchg(64)_local, so make the name more
accurate (HAVE_CMPXCHG_PERCPU_BYTE). Last, remove RISC-V's
cmpxchg(64)_local definition because it's no use.

Guo Ren (4):
vmstat: percpu: Rename HAVE_CMPXCHG_LOCAL to HAVE_CMPXCHG_PERCPU_BYTE
arm64: percpu: Use generic PERCPU_RW_OPS
riscv: percpu: Implement this_cpu operations
riscv: cmpxchg: Remove unused cmpxchg(64)_local

.../locking/cmpxchg-local/arch-support.txt | 6 +-
arch/Kconfig | 2 +-
arch/arm64/Kconfig | 2 +-
arch/arm64/include/asm/percpu.h | 33 ------
arch/riscv/include/asm/cmpxchg.h | 9 --
arch/riscv/include/asm/percpu.h | 104 ++++++++++++++++++
arch/s390/Kconfig | 2 +-
arch/x86/Kconfig | 2 +-
mm/vmstat.c | 4 +-
9 files changed, 113 insertions(+), 51 deletions(-)
create mode 100644 arch/riscv/include/asm/percpu.h

--
2.36.1