Re: [PATCH net-next v5 08/18] net: sparx5: Replace usage of found with dedicated list iterator variable

From: Paolo Abeni
Date: Thu Apr 28 2022 - 05:46:02 EST


Hello,

On Wed, 2022-04-27 at 18:06 +0200, Jakob Koschel wrote:
> To move the list iterator variable into the list_for_each_entry_*()
> macro in the future it should be avoided to use the list iterator
> variable after the loop body.
>
> To *never* use the list iterator variable after the loop it was
> concluded to use a separate iterator variable instead of a
> found boolean [1].
>
> This removes the need to use a found variable and simply checking if
> the variable was set, can determine if the break/goto was hit.
>
> Link: https://lore.kernel.org/all/CAHk-=wgRr_D8CB-D9Kg-c=EHreAsk5SqXPwr9Y7k9sA6cWXJ6w@xxxxxxxxxxxxxx/ [1]
> Signed-off-by: Jakob Koschel <jakobkoschel@xxxxxxxxx>
> ---
> .../microchip/sparx5/sparx5_mactable.c | 25 +++++++++----------
> 1 file changed, 12 insertions(+), 13 deletions(-)
>
> diff --git a/drivers/net/ethernet/microchip/sparx5/sparx5_mactable.c b/drivers/net/ethernet/microchip/sparx5/sparx5_mactable.c
> index a5837dbe0c7e..bb8d9ce79ac2 100644
> --- a/drivers/net/ethernet/microchip/sparx5/sparx5_mactable.c
> +++ b/drivers/net/ethernet/microchip/sparx5/sparx5_mactable.c
> @@ -362,8 +362,7 @@ static void sparx5_mact_handle_entry(struct sparx5 *sparx5,
> unsigned char mac[ETH_ALEN],
> u16 vid, u32 cfg2)
> {
> - struct sparx5_mact_entry *mact_entry;
> - bool found = false;
> + struct sparx5_mact_entry *mact_entry = NULL, *iter;
> u16 port;
>
> if (LRN_MAC_ACCESS_CFG_2_MAC_ENTRY_ADDR_TYPE_GET(cfg2) !=
> @@ -378,28 +377,28 @@ static void sparx5_mact_handle_entry(struct sparx5 *sparx5,
> return;
>
> mutex_lock(&sparx5->mact_lock);
> - list_for_each_entry(mact_entry, &sparx5->mact_entries, list) {
> - if (mact_entry->vid == vid &&
> - ether_addr_equal(mac, mact_entry->mac)) {
> - found = true;
> - mact_entry->flags |= MAC_ENT_ALIVE;
> - if (mact_entry->port != port) {
> + list_for_each_entry(iter, &sparx5->mact_entries, list) {
> + if (iter->vid == vid &&
> + ether_addr_equal(mac, iter->mac)) {

I'm sorry for the late feedback.

If you move the 'mact_entry = iter;' statement here, the diffstat will
be slightly smaller and the patch more readable, IMHO.

There is similar situation in the next patch.

Cheers,

Paolo