Re: [PATCH 03/21] ata: libahci_platform: Explicitly set rc on devres_alloc failure

From: Damien Le Moal
Date: Wed Mar 23 2022 - 20:58:45 EST


On 3/24/22 09:16, Serge Semin wrote:
> It's better for readability and maintainability to explicitly assign an
> error number to the variable used then as a return value from the method
> on the cleanup-on-error path. So adding new code in the method we won't

No it is not. On-stack variable initialization is not free. So if
initializing the variable is not needed, do not do it.

> have to think whether the overridden rc-variable is set afterward in case
> of an error. Saving one line of code doesn't worth it especially seeing
> the rest of the ahci_platform_get_resources() function errors handling
> blocks do explicitly write errno to rc.
>
> Signed-off-by: Serge Semin <Sergey.Semin@xxxxxxxxxxxxxxxxxxxx>
> ---
> drivers/ata/libahci_platform.c | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/ata/libahci_platform.c b/drivers/ata/libahci_platform.c
> index 18296443ccba..1bd2f1686239 100644
> --- a/drivers/ata/libahci_platform.c
> +++ b/drivers/ata/libahci_platform.c
> @@ -389,7 +389,7 @@ struct ahci_host_priv *ahci_platform_get_resources(struct platform_device *pdev,
> struct ahci_host_priv *hpriv;
> struct clk *clk;
> struct device_node *child;
> - int i, enabled_ports = 0, rc = -ENOMEM, child_nodes;
> + int i, enabled_ports = 0, rc = 0, child_nodes;
> u32 mask_port_map = 0;
>
> if (!devres_open_group(dev, NULL, GFP_KERNEL))
> @@ -397,8 +397,10 @@ struct ahci_host_priv *ahci_platform_get_resources(struct platform_device *pdev,
>
> hpriv = devres_alloc(ahci_platform_put_resources, sizeof(*hpriv),
> GFP_KERNEL);
> - if (!hpriv)
> + if (!hpriv) {
> + rc = -ENOMEM;
> goto err_out;
> + }

If you set rc to -ENOMEM here, then the 0 initialization of rc is not needed.

>
> devres_add(dev, hpriv);
>


--
Damien Le Moal
Western Digital Research