[PATCH] mm/ksm: use helper macro __ATTR_RW

From: Miaohe Lin
Date: Mon Feb 21 2022 - 06:59:00 EST


Use helper macro __ATTR_RW to define KSM_ATTR to make code more clear.
Minor readability improvement.

Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx>
---
mm/ksm.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/mm/ksm.c b/mm/ksm.c
index e246d650266a..ab52dbf4c5d5 100644
--- a/mm/ksm.c
+++ b/mm/ksm.c
@@ -2819,8 +2819,7 @@ static void wait_while_offlining(void)
#define KSM_ATTR_RO(_name) \
static struct kobj_attribute _name##_attr = __ATTR_RO(_name)
#define KSM_ATTR(_name) \
- static struct kobj_attribute _name##_attr = \
- __ATTR(_name, 0644, _name##_show, _name##_store)
+ static struct kobj_attribute _name##_attr = __ATTR_RW(_name)

static ssize_t sleep_millisecs_show(struct kobject *kobj,
struct kobj_attribute *attr, char *buf)
--
2.23.0