Re: [PATCHv2 22/29] x86/tdx: Make pages shared in ioremap()

From: Kirill A. Shutemov
Date: Tue Feb 15 2022 - 11:27:32 EST


On Tue, Feb 15, 2022 at 09:55:16AM -0600, Tom Lendacky wrote:
> On 2/15/22 09:41, Kirill A. Shutemov wrote:
> > On Tue, Feb 15, 2022 at 08:49:34AM -0600, Tom Lendacky wrote:
> > > On 2/14/22 16:09, Kirill A. Shutemov wrote:
> > > > On Mon, Feb 07, 2022 at 06:28:04PM +0100, Borislav Petkov wrote:
> > > > > On Mon, Feb 07, 2022 at 08:57:39AM -0800, Dave Hansen wrote:
> > > > > > We can surely *do* this with cc_something() helpers. It's just not as
> > > > > > easy as making cc_set/cc_clear().
> > > > >
> > > > > Sure, that's easy: cc_pgprot_{enc,dec}() or so.
> > > >
> > > > So, I've ended up with this in <asm/pgtable.h>
> > > >
> > > > /*
> > > > * Macros to add or remove encryption attribute
> > > > */
> > > > #ifdef CONFIG_ARCH_HAS_CC_PLATFORM
> > > > pgprotval_t cc_enc(pgprotval_t protval);
> > > > pgprotval_t cc_dec(pgprotval_t protval);
> > > > #define pgprot_encrypted(prot) __pgprot(cc_enc(pgprot_val(prot)))
> > > > #define pgprot_decrypted(prot) __pgprot(cc_dec(pgprot_val(prot)))
> > > > #else
> > > > #define pgprot_encrypted(prot) (prot)
> > > > #define pgprot_decrypted(prot) (prot)
> > > > #endif
> > >
> > > A couple of things. I think cc_pgprot_enc() and cc_pgprot_dec() would be
> > > more descriptive/better names to use here.
> > >
> > > Also, can they be defined in include/linux/cc_platform.h (with two versions
> > > based on CONFIG_ARCH_HAS_CC_PLATFORM) and have that included here? Or is
> > > there some header file include issues when trying to include it? That would
> > > clean this block up into just two lines.
> >
> > Well, pgprotval_t is x86-specific. It cannot be used in generic headers.
>
> Ah, right.
>
> > We can use u64 here instead. It is wider than pgprotval_t on 2-level
> > paging x86, but should work.
>
> Hmm..., yeah. Maybe unsigned long? CONFIG_ARCH_HAS_CC_PLATFORM is X86_64
> only, so 2-level paging wouldn't be applicable when an unsigned long is
> 64-bits?

Hm. So for !CONFIG_ARCH_HAS_CC_PLATFORM it has to be define, if we would
try static inline dummy instead it will break x86 PAE as upper bit get
trancated when passed via helper.

I donno.

> I'll let the maintainers weigh in on that.
>
> >
> > But with u64 as type, I'm not sure 'pgprot' in the name is jutified.
>
> Maybe cc_mask_{enc,dec}()? It just sounds like cc_{enc,dec}() is actually
> performing encryption or decryption and can be confusing.

cc_{enc,dec}_mask() sounds better to me.

--
Kirill A. Shutemov