Re: [PATCH v5 4/6] drm: Decouple nomodeset from CONFIG_VGA_CONSOLE

From: Jani Nikula
Date: Fri Nov 12 2021 - 09:06:14 EST


On Fri, 12 Nov 2021, Javier Martinez Canillas <javierm@xxxxxxxxxx> wrote:
> This relationship was only for historical reasons and the nomodeset option
> should be available even on platforms that don't enable CONFIG_VGA_CONSOLE.
>
> Suggested-by: Thomas Zimmermann <tzimmermann@xxxxxxx>
> Signed-off-by: Javier Martinez Canillas <javierm@xxxxxxxxxx>
> Acked-by: Thomas Zimmermann <tzimmermann@xxxxxxx>
> Acked-by: Jani Nikula <jani.nikula@xxxxxxxxx>
> Acked-by: Pekka Paalanen <pekka.paalanen@xxxxxxxxxxxxx>
> ---
>
> (no changes since v1)
>
> drivers/gpu/drm/Kconfig | 6 ++++++
> drivers/gpu/drm/Makefile | 2 +-
> include/drm/drm_drv.h | 4 ----
> 3 files changed, 7 insertions(+), 5 deletions(-)
>
> diff --git drivers/gpu/drm/Kconfig drivers/gpu/drm/Kconfig
> index fb144617055b..483d534eb074 100644
> --- drivers/gpu/drm/Kconfig
> +++ drivers/gpu/drm/Kconfig
> @@ -8,6 +8,7 @@
> menuconfig DRM
> tristate "Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)"
> depends on (AGP || AGP=n) && !EMULATED_CMPXCHG && HAS_DMA
> + select DRM_NOMODESET
> select DRM_PANEL_ORIENTATION_QUIRKS
> select HDMI
> select FB_CMDLINE
> @@ -493,6 +494,11 @@ config DRM_EXPORT_FOR_TESTS
> config DRM_PANEL_ORIENTATION_QUIRKS
> tristate
>
> +# Separate option because nomodeset parameter is global and expected built-in
> +config DRM_NOMODESET
> + bool
> + default n
> +
> config DRM_LIB_RANDOM
> bool
> default n
> diff --git drivers/gpu/drm/Makefile drivers/gpu/drm/Makefile
> index c74810c285af..fa16d3e0bbdc 100644
> --- drivers/gpu/drm/Makefile
> +++ drivers/gpu/drm/Makefile
> @@ -33,7 +33,7 @@ drm-$(CONFIG_DRM_PRIVACY_SCREEN) += drm_privacy_screen.o drm_privacy_screen_x86.
>
> obj-$(CONFIG_DRM_DP_AUX_BUS) += drm_dp_aux_bus.o
>
> -obj-$(CONFIG_VGA_CONSOLE) += drm_nomodeset.o
> +obj-$(CONFIG_DRM_NOMODESET) += drm_nomodeset.o
>
> drm_cma_helper-y := drm_gem_cma_helper.o
> obj-$(CONFIG_DRM_GEM_CMA_HELPER) += drm_cma_helper.o
> diff --git include/drm/drm_drv.h include/drm/drm_drv.h
> index 89e26a732175..da0c836fe8e1 100644
> --- include/drm/drm_drv.h
> +++ include/drm/drm_drv.h
> @@ -601,10 +601,6 @@ static inline bool drm_drv_uses_atomic_modeset(struct drm_device *dev)
>
> int drm_dev_set_unique(struct drm_device *dev, const char *name);
>
> -#ifdef CONFIG_VGA_CONSOLE
> extern bool drm_firmware_drivers_only(void);

I'm not bikeshedding this series anymore, but please follow up with a
patch removing the extern keyword. It's useless.

BR,
Jani.


> -#else
> -static inline bool drm_firmware_drivers_only(void) { return false; }
> -#endif
>
> #endif

--
Jani Nikula, Intel Open Source Graphics Center