Re: [PATCH] media: use swap() to make code cleaner

From: Hans Verkuil
Date: Mon Nov 08 2021 - 04:16:34 EST


On 04/11/2021 11:43, Andy Shevchenko wrote:
> On Wed, Nov 3, 2021 at 10:34 AM <davidcomponentone@xxxxxxxxx> wrote:
>> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
>> opencoding it.
>
> Same comments as per all your valuable contributions: just think more
> about the code that you are dealing with!
>
>> if (dev->fmt->uvswap) {
>> - tmp = base2;
>> - base2 = base3;
>> - base3 = tmp;
>> + swap(base2, base3);
>> }
>
> Have you run checkpatch? What did it say?
>

checkpatch says all is fine :-)

But yes, the {} can now be dropped. If I apply the patch, then run checkpatch,
it will indeed complain about the {}.

Regards,

Hans