Re: [PATCH 7/7] vfio/pci: Remove map-on-fault behavior

From: Peter Xu
Date: Tue Aug 10 2021 - 16:54:41 EST


On Thu, Aug 05, 2021 at 11:08:21AM -0600, Alex Williamson wrote:
> diff --git a/drivers/vfio/pci/vfio_pci_private.h b/drivers/vfio/pci/vfio_pci_private.h
> index 0aa542fa1e26..9aedb78a4ae3 100644
> --- a/drivers/vfio/pci/vfio_pci_private.h
> +++ b/drivers/vfio/pci/vfio_pci_private.h
> @@ -128,6 +128,7 @@ struct vfio_pci_device {
> bool needs_reset;
> bool nointx;
> bool needs_pm_restore;
> + bool zapped_bars;

Would it be nicer to invert the meaning of "zapped_bars" and rename it to
"memory_enabled"? Thanks,

--
Peter Xu