Re: [PATCH 1/3] mcb: Use DEFINE_RES_MEM() to simplify code

From: Leizhen (ThunderTown)
Date: Tue Jun 15 2021 - 21:31:43 EST




On 2021/6/15 23:42, Greg Kroah-Hartman wrote:
> On Tue, Jun 15, 2021 at 11:55:28PM +0900, Johannes Thumshirn wrote:
>> From: Zhen Lei <thunder.leizhen@xxxxxxxxxx>
>>
>> The value of '.end' should be "start + size - 1". So the previous writing
>> should have omitted subtracted 1.
>>
>> Signed-off-by: Zhen Lei <thunder.leizhen@xxxxxxxxxx>
>> Signed-off-by: Johannes Thumshirn <jth@xxxxxxxxxx>
>> ---
>> drivers/mcb/mcb-lpc.c | 13 ++-----------
>> 1 file changed, 2 insertions(+), 11 deletions(-)
>>
>> diff --git a/drivers/mcb/mcb-lpc.c b/drivers/mcb/mcb-lpc.c
>> index 506676754538..53decd89876e 100644
>> --- a/drivers/mcb/mcb-lpc.c
>> +++ b/drivers/mcb/mcb-lpc.c
>> @@ -105,17 +105,8 @@ static int mcb_lpc_create_platform_device(const struct dmi_system_id *id)
>> return ret;
>> }
>>
>> -static struct resource sc24_fpga_resource = {
>> - .start = 0xe000e000,
>> - .end = 0xe000e000 + CHAM_HEADER_SIZE,
>> - .flags = IORESOURCE_MEM,
>> -};
>> -
>> -static struct resource sc31_fpga_resource = {
>> - .start = 0xf000e000,
>> - .end = 0xf000e000 + CHAM_HEADER_SIZE,
>> - .flags = IORESOURCE_MEM,
>> -};
>> +static struct resource sc24_fpga_resource = DEFINE_RES_MEM(0xe000e000, CHAM_HEADER_SIZE);
>> +static struct resource sc31_fpga_resource = DEFINE_RES_MEM(0xf000e000, CHAM_HEADER_SIZE);
>
> Does this simplify stuff, or does it fix a bug with the existing
> definition?

It does not fix a bug, the actual value of .end should be "0xe000e000 + CHAM_HEADER_SIZE - 1".
There is no functional problem, just a little more memory. So it's just been corrected in the
process of simplification.

Do you think it's necessary to split it into two patches?

>
> Your changelog text says one thing, but your subject says the other...

Okay, I'll change the description. How about:
Use DEFINE_RES_MEM() to save a couple of lines of code, which makes the
code a bit shorter and easier to read. The start address does not need to
appear twice.

By the way, the value of '.end' should be "start + size - 1". So the
previous writing should have omitted subtracted 1.

>
> thanks,
>
> greg k-h
>
> .
>