Re: [PATCH] staging: vt6656: fixed a CamelCase coding style issue.

From: Greg KH
Date: Fri Feb 19 2021 - 05:41:01 EST


On Fri, Feb 19, 2021 at 03:28:35PM +0530, Selvakumar Elangovan wrote:
> This patch renames CamelCase macros uVar and uModulo into u_var and
> u_module in device.h
>
> This issue was reported by checkpatch.pl
>
> Signed-off-by: Selvakumar Elangovan <selvakumar16197@xxxxxxxxx>
> ---
> drivers/staging/vt6656/device.h | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/vt6656/device.h b/drivers/staging/vt6656/device.h
> index 947530fefe94..6615d356f74a 100644
> --- a/drivers/staging/vt6656/device.h
> +++ b/drivers/staging/vt6656/device.h
> @@ -385,11 +385,11 @@ struct vnt_private {
> struct ieee80211_low_level_stats low_stats;
> };
>
> -#define ADD_ONE_WITH_WRAP_AROUND(uVar, uModulo) { \
> - if ((uVar) >= ((uModulo) - 1)) \
> - (uVar) = 0; \
> +#define ADD_ONE_WITH_WRAP_AROUND(u_var, u_modulo) { \

"u_" does not really make any sense, right?

Just use "var" and "modulo" please.

But first, why is this needed at all? Isn't there an in-kernel function
that should be used instead?

thanks,

greg k-h