Re: [PATCH 4/5] gpio: xilinx: Utilize generic bitmap_get_value and _set_value

From: Linus Walleij
Date: Sun Dec 27 2020 - 16:30:48 EST


On Sat, Dec 26, 2020 at 7:44 AM Syed Nayyar Waris <syednwaris@xxxxxxxxx> wrote:

> This patch reimplements the xgpio_set_multiple() function in
> drivers/gpio/gpio-xilinx.c to use the new generic functions:
> bitmap_get_value() and bitmap_set_value(). The code is now simpler
> to read and understand. Moreover, instead of looping for each bit
> in xgpio_set_multiple() function, now we can check each channel at
> a time and save cycles.
>
> Cc: William Breathitt Gray <vilhelm.gray@xxxxxxxxx>
> Cc: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx>
> Cc: Michal Simek <michal.simek@xxxxxxxxxx>
> Signed-off-by: Syed Nayyar Waris <syednwaris@xxxxxxxxx>

(...)

> +#include <../drivers/gpio/clump_bits.h>

What is this?

Isn't a simple

#include "clump_bits.h"

enough?

We need an ACK from the Xilinx people that they think this
actually improves the readability and maintainability of their
driver.

Yours,
Linus Walleij