Re: [PATCH -next] platform: surface: fix non-PM_SLEEP build warnings

From: Maximilian Luz
Date: Fri Dec 11 2020 - 16:02:55 EST


On 12/11/20 9:41 PM, Randy Dunlap wrote:
On 12/11/20 12:23 PM, Maximilian Luz wrote:
On 12/11/20 8:03 PM, Randy Dunlap wrote:
Fix build warnings when CONFIG_PM_SLEEP is not enabled and these
functions are not used:

../drivers/platform/surface/surface_gpe.c:189:12: warning: ‘surface_gpe_resume’ defined but not used [-Wunused-function]
  static int surface_gpe_resume(struct device *dev)
             ^~~~~~~~~~~~~~~~~~
../drivers/platform/surface/surface_gpe.c:184:12: warning: ‘surface_gpe_suspend’ defined but not used [-Wunused-function]
  static int surface_gpe_suspend(struct device *dev)
             ^~~~~~~~~~~~~~~~~~~

Fixes: 274335f1c557 ("platform/surface: Add Driver to set up lid GPEs on MS Surface device")
Signed-off-by: Randy Dunlap <rdunlap@xxxxxxxxxxxxx>
Cc: Maximilian Luz <luzmaximilian@xxxxxxxxx>
Cc: Hans de Goede <hdegoede@xxxxxxxxxx>
Cc: platform-driver-x86@xxxxxxxxxxxxxxx
---
  drivers/platform/surface/surface_gpe.c |    2 ++
  1 file changed, 2 insertions(+)

--- linux-next-20201210.orig/drivers/platform/surface/surface_gpe.c
+++ linux-next-20201210/drivers/platform/surface/surface_gpe.c
@@ -181,6 +181,7 @@ static int surface_lid_enable_wakeup(str
      return 0;
  }
  +#ifdef CONFIG_PM_SLEEP
  static int surface_gpe_suspend(struct device *dev)
  {
      return surface_lid_enable_wakeup(dev, true);
@@ -190,6 +191,7 @@ static int surface_gpe_resume(struct dev
  {
      return surface_lid_enable_wakeup(dev, false);
  }
+#endif
    static SIMPLE_DEV_PM_OPS(surface_gpe_pm, surface_gpe_suspend, surface_gpe_resume);

Right, thanks.

I assume this covers all instances of this warning in platform/surface?
Otherwise, a "platform: surface: gpe: ..." subject would make more sense.

It should cover all of surface/. It was an allmodconfig and then I disabled
CONFIG_PM and CONFIG_PM_SLEEP etc.

Perfect, thanks!

As for prefixes, how many levels do we want to use?
(that's mostly rhetorical, although I would read answers :)

Looking at platform/x86 and past commit messages, I'd prefer something
like

platform/surface: <component>: <message>

This would be similar to the platform/x86 style. So two or three,
depending on how you count "platform/surface". I agree that this
probably tends to get a bit long, so I propose we drop the surface_
prefix on the component part to help with that. So, for example,
"surface_gpe" will become "gpe".


As for the rest:

Reviewed-by: Maximilian Luz <luzmaximilian@xxxxxxxxx>

thanks.


Regards,
Max