Re: [PATCH -next] usb: serial: simplify the ark3116_write_reg()

From: Johan Hovold
Date: Wed Dec 09 2020 - 05:55:46 EST


On Wed, Dec 09, 2020 at 05:29:17PM +0800, Zheng Yongjun wrote:
> Simplify the return expression.
>
> Signed-off-by: Zheng Yongjun <zhengyongjun3@xxxxxxxxxx>
> ---
> drivers/usb/serial/ark3116.c | 13 ++++---------
> 1 file changed, 4 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/usb/serial/ark3116.c b/drivers/usb/serial/ark3116.c
> index 71a9206ea1e2..0f9fa0e7c50e 100644
> --- a/drivers/usb/serial/ark3116.c
> +++ b/drivers/usb/serial/ark3116.c
> @@ -77,16 +77,11 @@ struct ark3116_private {
> static int ark3116_write_reg(struct usb_serial *serial,
> unsigned reg, __u8 val)
> {
> - int result;
> /* 0xfe 0x40 are magic values taken from original driver */
> - result = usb_control_msg(serial->dev,
> - usb_sndctrlpipe(serial->dev, 0),
> - 0xfe, 0x40, val, reg,
> - NULL, 0, ARK_TIMEOUT);
> - if (result)
> - return result;

Since none of the callers bother to check for errors, how about you add
a dev_err() here similar to the one in ark3116_read_reg() instead?

> -
> - return 0;

Keeping the explicit zero-return on success has the benefit of allowing
the casual developer to know what to expect when using this helper
without having to read the documentation (or implementation) of
usb_control_msg().

> + return usb_control_msg(serial->dev,
> + usb_sndctrlpipe(serial->dev, 0),
> + 0xfe, 0x40, val, reg,
> + NULL, 0, ARK_TIMEOUT);
> }
>
> static int ark3116_read_reg(struct usb_serial *serial,

Johan