Re: [PATCH v3] mm/oom_kill: remove comment and rename is_dump_unreclaim_slabs()

From: Michal Hocko
Date: Thu Oct 29 2020 - 04:04:55 EST


On Wed 28-10-20 14:53:30, Andrew Morton wrote:
> On Wed, 28 Oct 2020 23:31:41 +0800 Hui Su <sh_def@xxxxxxx> wrote:
>
> > Comment for is_dump_unreclaim_slabs is not really clear whether it is
> > meant to instruct how to use the function or whether it is an outdated
> > information of the past implementation of the function. it doesn't realy
> > help that is_dump_unreclaim_slabs is hard to grasp on its own.
> >
> > Rename the helper to should_dump_unreclaim_slabs which should make it
> > clear what it is meant to do and drop the comment as the purpose
> > should be pretty evident now.
> >
>
> I think your recent attempt to improve the comment:
>
> /*
> * Check whether unreclaimable slabs amount is greater than all user
> * memory(LRU pages).
> */
>
> was actually somewhat useful, and worth retaining.
>
> It would be better if it explained *why* we're doing this, rather than
> simply "what we are doing"?
>
> <looks at the code>
>
> It's actually quite unobvious why we're doing this!

It's quite arbitrary criterion to print slab information in the oom
report. The current logic is to dump if there is more slabs than LRU
pages which should be pretty obvious from the code. Why this rather than
e.g. slab * k > lru? Well, no strong reason, AFAIK. We just want to
catch too much slab memory cases.

--
Michal Hocko
SUSE Labs