Re: [linux-next PATCH 1/2] mm: khugepaged: add exceed_max_ptes_* helpers

From: Yang Shi
Date: Thu Apr 30 2020 - 20:01:20 EST




On 4/30/20 2:59 PM, Kirill A. Shutemov wrote:
On Thu, Apr 30, 2020 at 06:56:21AM +0800, Yang Shi wrote:
The max_ptes_{swap|none|shared} are defined to tune the behavior of
khugepaged. The are checked at a couple of places with open coding.
Replace the opencoding to exceed_pax_ptes_{swap|none_shared} helpers to
improve the readability.

Cc: Kirill A. Shutemov <kirill.shutemov@xxxxxxxxxxxxxxx>
Cc: Hugh Dickins <hughd@xxxxxxxxxx>
Cc: Andrea Arcangeli <aarcange@xxxxxxxxxx>
Signed-off-by: Yang Shi <yang.shi@xxxxxxxxxxxxxxxxx>
---
mm/khugepaged.c | 27 +++++++++++++++++++++------
1 file changed, 21 insertions(+), 6 deletions(-)

diff --git a/mm/khugepaged.c b/mm/khugepaged.c
index a02a4c5..0c8d30b 100644
--- a/mm/khugepaged.c
+++ b/mm/khugepaged.c
@@ -339,6 +339,21 @@ struct attribute_group khugepaged_attr_group = {
};
#endif /* CONFIG_SYSFS */
+static inline bool exceed_max_ptes_none(unsigned int *nr_ptes)
+{
+ return (++(*nr_ptes) > khugepaged_max_ptes_none);
+}
+
+static inline bool exceed_max_ptes_swap(unsigned int *nr_ptes)
+{
+ return (++(*nr_ptes) > khugepaged_max_ptes_swap);
+}
+
+static inline bool exceed_max_ptes_shared(unsigned int *nr_ptes)
+{
+ return (++(*nr_ptes) > khugepaged_max_ptes_shared);
+}
+
Frankly, I find this ugly and confusing. Open-coded version is more
readable to me.

I'm sorry you feel that way. I tend to agree that dereference looks not good. The open-coded version is not hard to understand to me either.

They are checked at a couple of different places with different variables, i.e. unmapped vs swap, and with different comparisons, > vs <=. I just thought the helpers with unified name started with "exceed_" may make it more self-explained and readable. Anyway this totally depends on taste and I really don't insist on this change.