Re: [PATCH v2 2/2] x86/delay: Introduce TPAUSE delay

From: Andy Lutomirski
Date: Fri Mar 20 2020 - 19:57:18 EST


On Fri, Mar 20, 2020 at 4:23 PM Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:
>
> Andy Lutomirski <luto@xxxxxxxxxx> writes:
>
> > On Fri, Mar 20, 2020 at 3:00 AM Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:
> >>
> >> Andy Lutomirski <luto@xxxxxxxxxx> writes:
> >> > On Thu, Mar 19, 2020 at 9:13 PM Kyung Min Park <kyung.min.park@xxxxxxxxx> wrote:
> >> >> void use_tsc_delay(void)
> >> >> {
> >> >> - if (delay_fn == delay_loop)
> >> >> + if (static_cpu_has(X86_FEATURE_WAITPKG)) {
> >> >> + delay_halt_fn = delay_halt_tpause;
> >> >> + delay_fn = delay_halt;
> >> >> + } else if (delay_fn == delay_loop) {
> >> >> delay_fn = delay_tsc;
> >> >> + }
> >> >> }
> >> >
> >> > This is an odd way to dispatch: you're using static_cpu_has(), but
> >> > you're using it once to populate a function pointer. Why not just put
> >> > the static_cpu_has() directly into delay_halt() and open-code the
> >> > three variants?
> >>
> >> Two: mwaitx and tpause.
> >
> > I was imagining there would also be a variant for systems with neither feature.
>
> Oh I see, you want to get rid of both function pointers. That's tricky.
>
> The boot time function is delay_loop() which is using the magic (1 << 12)
> boot time value until calibration in one way or the other happens and
> something calls use_tsc_delay() or use_mwaitx_delay(). Yes, that's all
> horrible but X86_FEATURE_TSC is unusable for this.
>
> Let me think about it.

This is definitely not worth overoptimizing. It's a *delay* function
-- the retpoline isn't going to kill us :)

>
> Thanks,
>
> tglx
>
>
>
>
>
>
>
>