[PATCH v4 1/2] KVM: VMX: rename 'kvm_area' to 'vmxon_region'

From: Vitaly Kuznetsov
Date: Wed Mar 18 2020 - 13:18:04 EST


The name 'kvm_area' is misleading (as we have way too many areas which are
KVM related), what alloc_kvm_area()/free_kvm_area() functions really do is
allocate/free VMXON region for all CPUs. Rename accordingly.

No functional change intended.

Reviewed-by: Sean Christopherson <sean.j.christopherson@xxxxxxxxx>
Reviewed-by: Krish Sadhukhan <krish.sadhukhan@xxxxxxxxxx>
Signed-off-by: Vitaly Kuznetsov <vkuznets@xxxxxxxxxx>
---
arch/x86/kvm/vmx/vmx.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/arch/x86/kvm/vmx/vmx.c b/arch/x86/kvm/vmx/vmx.c
index b447d66f44e6..f7ee7c31fe8c 100644
--- a/arch/x86/kvm/vmx/vmx.c
+++ b/arch/x86/kvm/vmx/vmx.c
@@ -2622,7 +2622,7 @@ int alloc_loaded_vmcs(struct loaded_vmcs *loaded_vmcs)
return -ENOMEM;
}

-static void free_kvm_area(void)
+static void free_vmxon_regions(void)
{
int cpu;

@@ -2632,7 +2632,7 @@ static void free_kvm_area(void)
}
}

-static __init int alloc_kvm_area(void)
+static __init int alloc_vmxon_regions(void)
{
int cpu;

@@ -2641,7 +2641,7 @@ static __init int alloc_kvm_area(void)

vmcs = alloc_vmcs_cpu(false, cpu, GFP_KERNEL);
if (!vmcs) {
- free_kvm_area();
+ free_vmxon_regions();
return -ENOMEM;
}

@@ -7804,7 +7804,7 @@ static __init int hardware_setup(void)

vmx_set_cpu_caps();

- r = alloc_kvm_area();
+ r = alloc_vmxon_regions();
if (r)
nested_vmx_hardware_unsetup();
return r;
@@ -7815,7 +7815,7 @@ static __exit void hardware_unsetup(void)
if (nested)
nested_vmx_hardware_unsetup();

- free_kvm_area();
+ free_vmxon_regions();
}

static bool vmx_check_apicv_inhibit_reasons(ulong bit)
--
2.25.1