Re: [Patch v4 4/6] sched/fair: update cpu_capcity to reflect thermal pressure

From: Dietmar Eggemann
Date: Thu Oct 31 2019 - 12:17:13 EST


On 31.10.19 16:48, Vincent Guittot wrote:
> On Thu, 31 Oct 2019 at 16:38, Dietmar Eggemann <dietmar.eggemann@xxxxxxx> wrote:
>>
>> On 31.10.19 11:53, Qais Yousef wrote:
>>> On 10/28/19 16:30, Peter Zijlstra wrote:
>>>> On Wed, Oct 23, 2019 at 01:28:40PM +0100, Qais Yousef wrote:
>>>>> On 10/22/19 16:34, Thara Gopinath wrote:

[...]

>>> To make sure I got this correctly - it's because avg_thermal.load_avg
>>> represents delta_capacity which is already a 'converted' form of load. So this
>>> makes avg_thermal.load_avg a util_avg really. Correct?
>>>
>>> If I managed to get it right somehow. It'd be nice if we can do inverse
>>> conversion on delta_capacity so that avg_thermal.{load_avg, util_avg} meaning
>>> is consistent across the board. But I don't feel strongly about it if this gets
>>> documented properly.
>>
>> So why can't we use rq->avg_thermal.util_avg here? Since capacity is
>> closer to util than to load?
>>
>> Is it because you want to use the influence of ___update_load_sum(...,
>> unsigned long load eq. per-cpu delta_capacity in your signal?
>>
>> Why not call it this way then?
>
> util_avg tracks a binary state with 2 fixed weights: running(1024) vs
> not running (0)
> In the case of thermal pressure, we want to track how much pressure is
> put on the CPU: capping to half the max frequency is not the same as
> capping only 10%
> load_avg is not boolean but you set the weight you want to apply and
> this weight reflects the amount of pressure.

I see. This is what I meant by 'load (weight) eq. per-cpu delta_capacity
(pressure)'.


>> diff --git a/kernel/sched/pelt.c b/kernel/sched/pelt.c
>> index 38210691c615..d3035457483f 100644
>> --- a/kernel/sched/pelt.c
>> +++ b/kernel/sched/pelt.c
>> @@ -357,9 +357,9 @@ int update_thermal_load_avg(u64 now, struct rq *rq,
>> u64 capacity)
>> {
>> if (___update_load_sum(now, &rq->avg_thermal,
>> capacity,
>> - capacity,
>> - capacity)) {
>> - ___update_load_avg(&rq->avg_thermal, 1, 1);
>> + 0,
>> + 0)) {
>> + ___update_load_avg(&rq->avg_thermal, 1, 0);
>> return 1;
>> }

So we could call it this way since we don't care about runnable_load or
util?