Re: [PATCH 1/8] ftrace: add ftrace_init_nop()

From: Steven Rostedt
Date: Tue Oct 22 2019 - 08:54:33 EST


On Tue, 22 Oct 2019 12:28:11 +0100
Mark Rutland <mark.rutland@xxxxxxx> wrote:

> > To make the name even better, let's just rename it to:
> >
> > ftrace_nop_initialization()
> >
> > I think that may be the best description for it.
>
> Perhaps ftrace_nop_initialize(), so that it's not a noun?
>
> I've made it ftrace_nop_initialization() in my branch for now.

I'm fine with ftrace_nop_initialize().

>
> > > diff --git a/kernel/trace/ftrace.c b/kernel/trace/ftrace.c
> > > index f296d89be757..afd7e210e595 100644
> > > --- a/kernel/trace/ftrace.c
> > > +++ b/kernel/trace/ftrace.c
> > > @@ -2493,15 +2493,22 @@ struct dyn_ftrace *ftrace_rec_iter_record(struct ftrace_rec_iter *iter)
> > > return &iter->pg->records[iter->index];
> > > }
> > >
> > > +#ifndef ftrace_init_nop
> > > +static int ftrace_init_nop(struct module *mod, struct dyn_ftrace *rec)
> > > +{
> > > + return ftrace_make_nop(mod, rec, MCOUNT_ADDR);
> > > +}
> > > +#endif
> >
> > Can you place the above in the ftrace.h header. That's where that would
> > belong.
> >
> > #ifndef ftrace_init_nop
> > struct module;
> > static inline int ftrace_init_nop(struct module *mod, struct dyn_ftrace *rec)
> > {
> > return ftrace_make_nop(mod, rec, MCOUNT_ADDR);
> > }
> > #endif
>
> True.
>
> I've put this immediately after ftrace_make_nop() in the header, and
> given it a kerneldoc comment. There's a declaration for struct module at
> the top of the header, so I've just relied on that
>
> That looks like:
>
> | /**
> | * ftrace_init_nop - initialize a nop call site
> | * @mod: module structure if called by module load initialization
> | * @rec: the mcount call site record

Perhaps say "mcount/fentry"

> | *
> | * This is a very sensitive operation and great care needs
> | * to be taken by the arch. The operation should carefully
> | * read the location, check to see if what is read is indeed
> | * what we expect it to be, and then on success of the compare,
> | * it should write to the location.
> | *
> | * The code segment at @rec->ip should be as initialized by the

"should be as" is a bit confusing. What about?

"The code segment at @rec->ip should contain the contents created by
the compiler".

-- Steve


> | * compiler
> | *
> | * Return must be:
> | * 0 on success
> | * -EFAULT on error reading the location
> | * -EINVAL on a failed compare of the contents
> | * -EPERM on error writing to the location
> | * Any other value will be considered a failure.
> | */
> | #ifndef ftrace_init_nop
> | static int ftrace_init_nop(struct module *mod, struct dyn_ftrace *rec)
> | {
> | return ftrace_make_nop(mod, rec, MCOUNT_ADDR);
> | }
> | #endif
>
> Thanks,
> Mark.