Re: pselect/etc semantics

From: Eric W. Biederman
Date: Wed May 29 2019 - 21:57:51 EST


Arnd Bergmann <arnd@xxxxxxxx> writes:

> On Wed, May 29, 2019 at 6:12 PM Oleg Nesterov <oleg@xxxxxxxxxx> wrote:
>>
>> Al, Linus, Eric, please help.
>>
>> The previous discussion was very confusing, we simply can not understand each
>> other.
>>
>> To me everything looks very simple and clear, but perhaps I missed something
>> obvious? Please correct me.
>
> Thanks for the elaborate explanation in this patch, it all starts making sense
> to me now. I also looked at your patch in detail and thought I had found
> a few mistakes at first but those all turned out to be mistakes in my reading.
>
>> See the compile-tested patch at the end. Of course, the new _xxx() helpers
>> should be renamed somehow. fs/aio.c doesn't look right with or without this
>> patch, but iiuc this is what it did before 854a6ed56839a.
>
> I think this is a nice simplification, but it would help not to mix up the
> minimal regression fix with the rewrite of those functions. For the stable
> kernels, I think we want just the addition of the 'bool interrupted' argument
> to restore_user_sigmask() to close the race that was introduced
> 854a6ed56839a. Following up on that for future kernels, your patch
> improves the readability, but we can probably take it even further.
>
>> - ret = set_user_sigmask(ksig.sigmask, &ksigmask, &sigsaved, ksig.sigsetsize);
>> + ret = set_xxx(ksig.sigmask, ksig.sigsetsize);
>> if (ret)
>> return ret;
>>
>> ret = do_io_getevents(ctx_id, min_nr, nr, events, timeout ? &ts : NULL);
>> - restore_user_sigmask(ksig.sigmask, &sigsaved);
>> - if (signal_pending(current) && !ret)
>> +
>> + interrupted = signal_pending(current);
>> + update_xxx(interrupted);
>
> Maybe name this
>
> restore_saved_sigmask_if(!interrupted);
>
> and make restore_saved_sigmask_if() an inline function
> next to restore_saved_sigmask()?
>
>> @@ -2201,13 +2205,15 @@ COMPAT_SYSCALL_DEFINE6(io_pgetevents,
>> if (usig && copy_from_user(&ksig, usig, sizeof(ksig)))
>> return -EFAULT;
>>
>> - ret = set_compat_user_sigmask(ksig.sigmask, &ksigmask, &sigsaved, ksig.sigsetsize);
>> + ret = set_compat_xxx(ksig.sigmask, ksig.sigsetsize);
>> if (ret)
>> return ret;
>
> With some of the recent discussions about compat syscall handling,
> I now think that we want to just fold set_compat_user_sigmask()
> into set_user_sigmask() (whatever they get called in the end)
> with an in_compat_syscall() conditional inside it, and completely get
> rid of the COMPAT_SYSCALL_DEFINEx() definitions for those
> system calls for which this is the only difference.
>
> Unfortunately we still need the time32/time64 distinction, but removing
> syscall handlers is a significant cleanup here already, and we can
> move most of the function body of sys_io_pgetevents() into
> do_io_getevents() in the process. Same for some of the other calls.
>
> Not sure about the order of the cleanups, but probably something like
> this would work:
>
> 1. fix the race (to be backported)
> 2. unify set_compat_user_sigmask/set_user_sigmask
> 3. remove unneeded compat handlers
> 4. replace restore_user_sigmask with restore_saved_sigmask_if()
> 5. also unify compat_get_fd_set()/get_fd_set() and kill off
> compat select() variants.

Are new system calls added preventing a revert of the patch in question
for stable kernels?

Eric