Re: [PATCH] fs: use KERNEL_DS instead of get_ds()

From: Al Viro
Date: Fri Mar 01 2019 - 22:40:22 EST


On Fri, Mar 01, 2019 at 09:08:35PM +0100, Jann Horn wrote:
> get_ds() is a legacy name for KERNEL_DS; all architectures #define it to
> KERNEL_DS,

not quite - h8300 and m68k have it as (equivalent) static inline.

> and almost every user of set_fs() uses the name KERNEL_DS.
>
> Let the VFS also use KERNEL_DS so that we can get rid of get_ds() at some
> point.

No objections, but that kind of stuff might be better done in a different
way: ask Linus to run this

git grep -n -w get_ds | tr ':' ' ' | while read file line junk; do
case "$file" in
*include*|tools*)
;;
*)
ed $file <<EOF
${line}s/get_ds()/KERNEL_DS/
w
q
EOF
;;
esac
done

just before -rc1, then follow it up with "kill unused get_ds()" patch
right after -rc1.