Re: [PATCH] ARM: dts: imx: Add support for Logic PD i.MX6QD EVM

From: Adam Ford
Date: Tue Jan 22 2019 - 11:08:13 EST


On Tue, Jan 22, 2019 at 9:19 AM Fabio Estevam <festevam@xxxxxxxxx> wrote:
>
> Hi Adam,
>
> On Tue, Jan 22, 2019 at 12:07 PM Adam Ford <aford173@xxxxxxxxx> wrote:
>
> > + reg_audio: regulator-audio {
> > + pinctrl-names = "default";
> > + pinctrl-0 = <&pinctrl_reg_audio>;
> > + compatible = "regulator-fixed";
> > + regulator-name = "3v3_aud";
> > + regulator-min-microvolt = <3300000>;
> > + regulator-max-microvolt = <3300000>;
> > + gpio = <&gpio1 29 GPIO_ACTIVE_HIGH>;
> > + enable-active-high;
> > + regulator-always-on;
>
> It seems that the 'regulator-always-on' property is not needed in this case.
>
> > +&i2c1 {
> > + pinctrl-names = "default";
> > + pinctrl-0 = <&pinctrl_i2c1>;
> > + clock-frequency = <400000>;
> > + status = "okay";
> > +
> > + codec: wm8962@1a {
>
> Node name should be generic and label name should be specific, so:
>
> wm8962: codec@1a {
>
> > + chosen {
> > + stdout-path = &uart1;
> > + };
> > +
> > + memory@10000000 {
>
> Need to pass device_type = "memory";
>
> > + reg = <0x10000000 0x80000000>;
> > + };
> > +
> > + reg_wl18xx_vmmc: regulator-wl18xx {
> > + compatible = "regulator-fixed";
> > + regulator-name = "vwl1837";
> > + regulator-min-microvolt = <3300000>;
> > + regulator-max-microvolt = <3300000>;
> > + gpio = <&gpio7 0 GPIO_ACTIVE_HIGH>;
> > + startup-delay-us = <70000>;
> > + enable-active-high;
> > + };
> > +
>
> No need for this blank line.
>
> > +};
>
> > +&i2c3 {
> > + clock-frequency = <100000>;
> > + pinctrl-names = "default";
> > + pinctrl-0 = <&pinctrl_i2c3>;
> > + status = "okay";
> > +
> > + pmic: pfuze100@8 {
>
> pfuze100: pmic@8
>
> > + tmp102_0: tmp102@4a {
>
> generic node name, please.

I have two temperature sensors. Should I just call them tempsense0
and tempsense1?

>
> > + compatible = "ti,tmp102";
> > + reg = <0x4a>;
> > + pinctrl-names = "default";
> > + pinctrl-0 = <&pinctrl_tempsense>;
> > + interrupt-parent = <&gpio6>;
> > + interrupts = <15 IRQ_TYPE_LEVEL_LOW>;
> > + #thermal-sensor-cells = <1>;
> > + };
> > +
> > + tmp102_1: tmp102@49 {
>
> Ditto
>
> > + compatible = "ti,tmp102";
> > + reg = <0x49>;
> > + interrupt-parent = <&gpio6>;
> > + interrupts = <15 IRQ_TYPE_LEVEL_LOW>;
> > + #thermal-sensor-cells = <1>;
> > + };
> > +
> > + at24c64_mfg: at24@51 {

I have two eeproms. One is a programmed by the factory with info like
serial number, model name, etc. The other is blank and available for
users.

Should I name them something like 'eeprom_mfg' and 'eeprom_usr'?
>
> Ditto
>
> > + compatible = "atmel,24c64";
> > + pagesize = <32>;
> > + read-only; /* Manufacturing EEPROM programmed at factory */
> > + reg = <0x51>;
> > + };
> > +
> > + at24c64_usr: at24@52 {
>
> Ditto
>
> > + panel-lvds0 {
> > + compatible = "ampire,am800480b3tmqw";
>
> Could not found this compatible documented.

I'll pull this out in V2. I pushed a patch a while ago for this
display, but it's not been accepted yet, and I need to follow up on
this.
>
> > +&i2c1 {
> > + ili_touch: ilitouch@26 {
>
> Generic node name, please.
>
> > + compatible = "ili,ili2117a";
>
> Could not found this compatible documented.

I'll pull this out in V2. I have a working driver, but I haven't
pushed it yet. I'll add them back in once the driver's been pushed
and accepted.

thanks for reviewing this so quickly.

adam