Re: powerpc/hugetlbpage: Rmove unhelpful HUGEPD_*_SHIFT macros

From: Michael Ellerman
Date: Mon Jul 23 2018 - 11:11:30 EST


On Tue, 2018-07-17 at 04:24:30 UTC, David Gibson wrote:
> The HUGEPD_*_SHIFT macros are always defined to be PGDIR_SHIFT and
> PUD_SHIFT, and have to have those values to work properly. They once used
> to have different values, but that was really only because they were used
> to mean different things in different contexts.
>
> 6fa50483 "powerpc/mm/hugetlb: initialize the pagetable cache correctly for
> hugetlb" removed that double meaning, but left the now useless constants.
>
> Signed-off-by: David Gibson <david@xxxxxxxxxxxxxxxxxxxxx>

Applied to powerpc next, thanks.

https://git.kernel.org/powerpc/c/fdf743c5c51d5b45db4dada3910954

cheers