Re: [RFC 1/4] Uprobe: Rename map_info to uprobe_map_info

From: Srikar Dronamraju
Date: Wed Feb 28 2018 - 07:11:30 EST


>
> -static inline struct map_info *free_map_info(struct map_info *info)
> +static inline struct uprobe_map_info *
> +free_uprobe_map_info(struct uprobe_map_info *info)
> {
> - struct map_info *next = info->next;
> + struct uprobe_map_info *next = info->next;
> kfree(info);
> return next;
> }
>
> -static struct map_info *
> -build_map_info(struct address_space *mapping, loff_t offset, bool is_register)
> +static struct uprobe_map_info *
> +build_uprobe_map_info(struct address_space *mapping, loff_t offset,
> + bool is_register)

Imho, uprobe_build_map_info may be better than build_uprobe_map_info,
similarly uprobe_free_map_info.