RE: [PATCH v2 01/16] remoteproc: add rproc_va_to_pa function

From: Loic PALLARDY
Date: Fri Jan 12 2018 - 02:43:19 EST



Hi Bjorn,

Thanks for the review of this series.

> -----Original Message-----
> From: Bjorn Andersson [mailto:bjorn.andersson@xxxxxxxxxx]
> Sent: Thursday, December 14, 2017 1:31 AM
> To: Loic PALLARDY <loic.pallardy@xxxxxx>
> Cc: ohad@xxxxxxxxxx; linux-remoteproc@xxxxxxxxxxxxxxx; linux-
> kernel@xxxxxxxxxxxxxxx; Arnaud POULIQUEN <arnaud.pouliquen@xxxxxx>;
> benjamin.gaignard@xxxxxxxxxx
> Subject: Re: [PATCH v2 01/16] remoteproc: add rproc_va_to_pa function
>
> On Thu 30 Nov 08:46 PST 2017, Loic Pallardy wrote:
>
> > This new function translates CPU virtual address in
> > CPU physical one according to virtual address location.
> >
> > Signed-off-by: Loic Pallardy <loic.pallardy@xxxxxx>
> > ---
> > drivers/remoteproc/remoteproc_core.c | 13 ++++++++++++-
> > 1 file changed, 12 insertions(+), 1 deletion(-)
> >
> > diff --git a/drivers/remoteproc/remoteproc_core.c
> b/drivers/remoteproc/remoteproc_core.c
> > index eab14b4..faa18a7 100644
> > --- a/drivers/remoteproc/remoteproc_core.c
> > +++ b/drivers/remoteproc/remoteproc_core.c
> > @@ -139,6 +139,17 @@ static void rproc_disable_iommu(struct rproc
> *rproc)
> > iommu_domain_free(domain);
> > }
> >
> > +static phys_addr_t rproc_va_to_pa(void *cpu_addr)
> > +{
> > + if (is_vmalloc_addr(cpu_addr)) {
>
> Please add a comment describing when is_vmalloc_addr() would be true.
Yes sure.
Regards,
Loic
>
> > + return page_to_phys(vmalloc_to_page(cpu_addr)) +
> > + offset_in_page(cpu_addr);
> > + }
> > +
> > + WARN_ON(!virt_addr_valid(cpu_addr));
> > + return virt_to_phys(cpu_addr);
> > +}
> > +
> > /**
> > * rproc_da_to_va() - lookup the kernel virtual address for a remoteproc
> address
> > * @rproc: handle of a remote processor
> > @@ -700,7 +711,7 @@ static int rproc_handle_carveout(struct rproc
> *rproc,
> > * In this case, the device address and the physical address
> > * are the same.
> > */
> > - rsc->pa = dma;
> > + rsc->pa = (u32)rproc_va_to_pa(va);
>
> This is more correct than using "dma", so this is good.
>
> Regards,
> Bjorn