Re: [PATCH] x86/mm: Rewrite sme_populate_pgd() in a more sensible way

From: Kirill A. Shutemov
Date: Mon Dec 04 2017 - 09:58:04 EST


On Mon, Dec 04, 2017 at 08:19:11AM -0600, Tom Lendacky wrote:
> On 12/4/2017 5:23 AM, Kirill A. Shutemov wrote:
> > sme_populate_pgd() open-codes a lot of things that are not needed to be
> > open-coded.
> >
> > Let's rewrite it in a more stream-lined way.
> >
> > This would also buy us boot-time switching between support between
> > paging modes, when rest of the pieces will be upstream.
>
> Hi Kirill,
>
> Unfortunately, some of these can't be changed. The use of p4d_offset(),
> pud_offset(), etc., use non-identity mapped virtual addresses which cause
> failures at this point of the boot process.

Wat? Virtual address is virtual address. p?d_offset() doesn't care about
what mapping you're using.

> Also, calls such as __p4d(), __pud(), etc., are part of the paravirt
> support and can't be used yet, either.

Yeah, I missed this. native_make_p?d() has to be used instead.

> I can take a closer look at some of the others (p*d_none() and
> p*d_large()) which make use of the native_ macros, but my worry would be
> that these get changed in the future to the non-native calls and then
> boot failures occur.

If you want to avoid paravirt altogher for whole compilation unit, one
more option would be to put #undef CONFIG_PARAVIRT before all includes.
That's hack, but it works. We already use this in arch/x86/boot/compressed
code.

--
Kirill A. Shutemov