Re: [PATCH v2 10/18] x86/asm: Remap the TSS into the cpu entry area

From: Andy Lutomirski
Date: Thu Nov 23 2017 - 23:17:59 EST


On Thu, Nov 23, 2017 at 6:40 PM, Andy Lutomirski <luto@xxxxxxxxxx> wrote:
> On Thu, Nov 23, 2017 at 12:37 PM, Borislav Petkov <bp@xxxxxxx> wrote:
>> On Thu, Nov 23, 2017 at 12:15:14PM -0800, Andy Lutomirski wrote:
>>> >> diff --git a/arch/x86/kernel/asm-offsets.c b/arch/x86/kernel/asm-offsets.c
>>> >> index b275863128eb..55858b277cf6 100644
>>> >> --- a/arch/x86/kernel/asm-offsets.c
>>> >> +++ b/arch/x86/kernel/asm-offsets.c
>>> >> @@ -98,4 +98,7 @@ void common(void) {
>>> >> OFFSET(CPU_TSS_SYSENTER_stack, tss_struct, SYSENTER_stack);
>>> >> /* Size of SYSENTER_stack */
>>> >> DEFINE(SIZEOF_SYSENTER_stack, sizeof(((struct tss_struct *)0)->SYSENTER_stack));
>>> >> +
>>> >> + /* Layout info for cpu_entry_area */
>>> >> + OFFSET(CPU_ENTRY_AREA_tss, cpu_entry_area, tss);
>>> >
>>> > The naming convention of those looks really strange. The beginning is in
>>> > all caps and then small. Can we choose a convention pls.
>>>
>>> This is actually consistent with the rest of the offsets. The
>>> convention is STRUCT_field.
>>
>> Except CPU_TSS_SYSENTER_stack. TSS_STRUCT_SYSENTER_stack I guess.
>
> Hmm, that name predates this series. I'll clean it up in a new patch
> at the end of the series.

I'm also going to leave the end-of-line comment alone for now. We can
maybe make that change to a bunch of comments later on.