Re: [PATCH net-next 1/4] device_cgroup: prepare code for bpf-based device controller

From: David Miller
Date: Thu Nov 02 2017 - 03:28:16 EST


From: Roman Gushchin <guro@xxxxxx>
Date: Wed, 1 Nov 2017 11:20:34 -0400

> diff --git a/include/linux/device_cgroup.h b/include/linux/device_cgroup.h
> index 8b64221b432b..25f1dc7673db 100644
> --- a/include/linux/device_cgroup.h
> +++ b/include/linux/device_cgroup.h
> @@ -1,16 +1,69 @@
> #include <linux/fs.h>
>
> +#define ACC_MKNOD 1
> +#define ACC_READ 2
> +#define ACC_WRITE 4
> +#define ACC_MASK (ACC_MKNOD | ACC_READ | ACC_WRITE)
> +
> +#define DEV_BLOCK 1
> +#define DEV_CHAR 2
> +#define DEV_ALL 4 /* this represents all devices */

When these macros existed solely inside of security/device_cgroup.c,
such naming was probably fine.

But once you move them into a global header file, we have to take
global namespace issues into consideration.

I would therefore like to ask that you give some kind of appropriate
prefix to the names of these macros, in order to make them more global
namespace friendly.

Thank you.