Re: [PATCH v2 4/7] gpio: mockup: improve readability

From: Bartosz Golaszewski
Date: Wed May 31 2017 - 06:53:12 EST


2017-05-30 20:55 GMT+02:00 Andy Shevchenko <andy.shevchenko@xxxxxxxxx>:
> On Tue, May 30, 2017 at 11:58 AM, Bartosz Golaszewski <brgl@xxxxxxxx> wrote:
>> We currently shift bits here and there without actually explaining
>> what we're doing. Add some helper variables with names indicating
>> their purpose to improve the code readability.
>
>> + /* Each chip is described by two values. */
>> + num_chips = gpio_mockup_params_nr / 2;
>> +
>> + chips = devm_kzalloc(dev, sizeof(*chips) * num_chips, GFP_KERNEL);
>
> It's effectively
> devm_kcalloc()
> or
> devm_kmalloc_array()
> depending on the requirement of zeroing a memory chunks.
>

Is there any advantage to using one of these here?

Thanks,
Bartosz