Re: [PATCH v2] USB hub_probe: remove ugly goto-into-compound-statement

From: Greg Kroah-Hartman
Date: Mon Nov 07 2016 - 04:09:17 EST


On Wed, Nov 02, 2016 at 08:59:44PM +0300, Eugene Korenevsky wrote:
> Rework smelling code (goto inside compound statement). Perhaps this is legacy.
> Anyway such code is not appropriate for Linux kernel.
>
> Signed-off-by: Eugene Korenevsky <ekorenevsky@xxxxxxxxx>
> ---
> drivers/usb/core/hub.c | 24 +++++++++++-------------
> 1 file changed, 11 insertions(+), 13 deletions(-)

What changed from v1?



>
> diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
> index cbb1467..4081672 100644
> --- a/drivers/usb/core/hub.c
> +++ b/drivers/usb/core/hub.c
> @@ -1802,23 +1802,21 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
>
> /* Some hubs have a subclass of 1, which AFAICT according to the */
> /* specs is not defined, but it works */
> - if ((desc->desc.bInterfaceSubClass != 0) &&
> - (desc->desc.bInterfaceSubClass != 1)) {
> -descriptor_error:
> +
> + /* Reject in following cases:
> + * - Interface subclass is not 0 or 1
> + * - Multiple endpoints
> + * - Not an interrupt in endpoint
> + */
> + endpoint = &desc->endpoint[0].desc;
> + if ((desc->desc.bInterfaceSubClass != 0 &&
> + desc->desc.bInterfaceSubClass != 1) ||
> + desc->desc.bNumEndpoints != 1 ||
> + !usb_endpoint_is_int_in(endpoint)) {
> dev_err(&intf->dev, "bad descriptor, ignoring hub\n");
> return -EIO;
> }
>
> - /* Multiple endpoints? What kind of mutant ninja-hub is this? */
> - if (desc->desc.bNumEndpoints != 1)
> - goto descriptor_error;
> -
> - endpoint = &desc->endpoint[0].desc;
> -
> - /* If it's not an interrupt in endpoint, we'd better punt! */
> - if (!usb_endpoint_is_int_in(endpoint))
> - goto descriptor_error;
> -

As "horrible" as the original code might be, it's much easier to read
and follow, which is the key thing here, right? What's so bad about a
goto backwards?

thanks,

greg k-h