Re: [PATCH] staging: sm750fb: rename macro roundedDiv to rounded_div in ddk750_chip.c

From: Greg KH
Date: Sun Oct 02 2016 - 05:48:00 EST


On Sun, Oct 02, 2016 at 08:48:32AM +0300, Moshe Green wrote:
> Rename CamelCased macro roundedDiv to rounded_div.
>
> This issue was found by checkpatch.pl
>
> Signed-off-by: Moshe Green <mgmoshes@xxxxxxxxx>
> ---
> drivers/staging/sm750fb/ddk750_chip.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/sm750fb/ddk750_chip.c b/drivers/staging/sm750fb/ddk750_chip.c
> index 3a0afe1..e4efe91 100644
> --- a/drivers/staging/sm750fb/ddk750_chip.c
> +++ b/drivers/staging/sm750fb/ddk750_chip.c
> @@ -7,7 +7,7 @@
> #include "ddk750_power.h"
>
> /* n / d + 1 / 2 = (2n + d) / 2d */
> -#define roundedDiv(num, denom) ((2 * (num) + (denom)) / (2 * (denom)))
> +#define rounded_div(num, denom) ((2 * (num) + (denom)) / (2 * (denom)))

Shouldn't you use the in-kernel function for this instead?