Re: [PATCH v4 5/5] gpio: pca953x: coding style fixes

From: Andy Shevchenko
Date: Wed Sep 07 2016 - 11:17:54 EST


On Wed, 2016-09-07 at 16:49 +0200, Bartosz Golaszewski wrote:
> pca953x_gpio_set_multiple() has some coding style issues that make it
> harder to read. Tweak the code a bit.
>

Usually give one day for reviewers to have a chance to follow your
changes.

And one comment below.

> Signed-off-by: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx>
> Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> ---
> Âdrivers/gpio/gpio-pca953x.c | 22 ++++++++++++----------
> Â1 file changed, 12 insertions(+), 10 deletions(-)
>
> diff --git a/drivers/gpio/gpio-pca953x.c b/drivers/gpio/gpio-pca953x.c
> index b08ed52..079c311 100644
> --- a/drivers/gpio/gpio-pca953x.c
> +++ b/drivers/gpio/gpio-pca953x.c
> @@ -360,25 +360,27 @@ exit:
> Â}
> Â
> Âstatic void pca953x_gpio_set_multiple(struct gpio_chip *gc,
> - unsigned long *mask, unsigned long *bits)
> + ÂÂÂÂÂÂunsigned long *mask, unsigned
> long *bits)
> Â{
> Â struct pca953x_chip *chip = gpiochip_get_data(gc);
> + unsigned int bankmask, bankval;
> + int bank_shift, bank, ret;
> Â u8 reg_val[MAX_BANK];
> - int ret;
> - int bank_shift = fls((chip->gpio_chip.ngpio - 1) / BANK_SZ);
> - int bank;

I meant to keep int ret apart.

struct pca953x_chip *chip = gpiochip_get_data(gc);
unsigned int bank_mask, bank_val, bank_shift, bank;
u8 reg_val[MAX_BANK];
int ret;

And perhaps _ in the names of bank* to be consistent.


--
Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
Intel Finland Oy