Re: [PATCH 0063/1285] Replace numeric parameter like 0444 with macro

From: Sergei Shtylyov
Date: Tue Aug 02 2016 - 08:35:46 EST


Hello.

On 8/2/2016 2:30 PM, Sergei Shtylyov wrote:

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the
corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@xxxxxxxxx>
Signed-off-by: Baole Ni <baolex.ni@xxxxxxxxx>
---
drivers/ata/pata_legacy.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/ata/pata_legacy.c b/drivers/ata/pata_legacy.c
index bce2a8c..1dc0beb 100644
--- a/drivers/ata/pata_legacy.c
+++ b/drivers/ata/pata_legacy.c
@@ -76,7 +76,7 @@
#define NR_HOST 6

static int all;
-module_param(all, int, 0444);
+module_param(all, int, S_IRUSR | S_IRGRP | S_IROTH);

There's S_IRUGO for this case, no?

Sending 1285 patches with the same subject also was a bad idea. You need a subsystem/driver prefix in order to somehow differ them.

MBR, Sergei