Re: [PATCH v6 08/11] tpm: Driver for supporting multiple emulated TPMs

From: Jarkko Sakkinen
Date: Fri Mar 11 2016 - 05:21:17 EST


On Thu, Mar 10, 2016 at 12:32:15PM -0500, Stefan Berger wrote:
> On 03/10/2016 11:39 AM, Jarkko Sakkinen wrote:
> >+/* above flags */
> >+#define VTPM_FLAG_TPM2 1 /* emulator is TPM 2 */
> >+
> >+/* all supported flags */
> >+#define VTPM_FLAGS_ALL (VTPM_FLAG_TPM2)
> >+
> >+#define VTPM_TPM 0xa0

A better name would be VTPM_IOC_MAGIC. You should also update
Documentation/ioctl/ioctl-number.txt.

> >+
> >+#define VTPM_NEW_DEV _IOW(VTPM_TPM, 0x00, struct vtpm_new_dev)
> >I'd rather use VTPM_IOC_NEW_DEV.
>
> What about the name of the structure ? vtpm_ioc_new_dev?

If I look at other subsystems like drm the common practice is either
name the ioctl as VTPM_NEW_DEV_IOCTL or VTPM_IOC_NEW_DEV and not have
suffix or postfix in the parameter struct. I would just copy that
convention here.

> Stefan

/Jarkko