Re: [PATCH v3 2/4] KVM: x86: Use vector-hashing to deliver lowest-priority interrupts

From: Radim KrÄmÃÅ
Date: Thu Jan 21 2016 - 14:49:59 EST


2016-01-20 09:42+0800, Feng Wu:
> Use vector-hashing to deliver lowest-priority interrupts, As an
> example, modern Intel CPUs in server platform use this method to
> handle lowest-priority interrupts.
>
> Signed-off-by: Feng Wu <feng.wu@xxxxxxxxx>
> ---

Functionality looks good, so I had a lot of stylistic comments, sorry :)

> v3:
> - Fix a bug for sparse topologies, in that case, vcpu_id is not equal
> to the return value got by kvm_get_vcpu().
> - Remove unnecessary check in fast irq delivery patch.
> - print a error message only once for each guest when we find hardware
> disabled LAPIC during interrupt injection.
> diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h
> @@ -754,6 +754,8 @@ struct kvm_arch {
>
> bool irqchip_split;
> u8 nr_reserved_ioapic_pins;
> +
> + int disabled_lapic_found;

Fits into "bool".

> };
>
> struct kvm_vm_stat {
> diff --git a/arch/x86/kvm/irq_comm.c b/arch/x86/kvm/irq_comm.c
> @@ -34,6 +34,7 @@
> #include "lapic.h"
>
> #include "hyperv.h"
> +#include "x86.h"
>
> static int kvm_set_pic_irq(struct kvm_kernel_irq_routing_entry *e,
> struct kvm *kvm, int irq_source_id, int level,
> @@ -55,8 +56,10 @@ static int kvm_set_ioapic_irq(struct kvm_kernel_irq_routing_entry *e,
> int kvm_irq_delivery_to_apic(struct kvm *kvm, struct kvm_lapic *src,
> struct kvm_lapic_irq *irq, unsigned long *dest_map)
> {
> - int i, r = -1;
> + int i, r = -1, idx = 0;

(No need to initialize idx.)

> struct kvm_vcpu *vcpu, *lowest = NULL;
> + unsigned long dest_vcpu_bitmap[BITS_TO_LONGS(KVM_MAX_VCPUS)];
> + unsigned int dest_vcpus = 0;
>
> if (irq->dest_mode == 0 && irq->dest_id == 0xff &&
> kvm_lowest_prio_delivery(irq)) {
> @@ -80,13 +85,25 @@ int kvm_irq_delivery_to_apic(struct kvm *kvm, struct kvm_lapic *src,
> r = 0;
> r += kvm_apic_set_irq(vcpu, irq, dest_map);
> } else if (kvm_lapic_enabled(vcpu)) {
> - if (!lowest)
> - lowest = vcpu;
> - else if (kvm_apic_compare_prio(vcpu, lowest) < 0)
> - lowest = vcpu;
> + if (!kvm_vector_hashing_enabled()) {
> + if (!lowest)
> + lowest = vcpu;
> + else if (kvm_apic_compare_prio(vcpu, lowest) < 0)
> + lowest = vcpu;
> + } else {
> + __set_bit(i, dest_vcpu_bitmap);
> + dest_vcpus++;
> + }
> }
> }
>
> + if (dest_vcpus != 0) {

(I think it's ok to do 'int idx = kvm...')

> + idx = kvm_vector_2_index(irq->vector, dest_vcpus,
> + dest_vcpu_bitmap, KVM_MAX_VCPUS);
> +
> + lowest = kvm_get_vcpu(kvm, idx - 1);
> + }
> +
> if (lowest)
> r = kvm_apic_set_irq(lowest, irq, dest_map);
>
> diff --git a/arch/x86/kvm/lapic.c b/arch/x86/kvm/lapic.c
> @@ -675,6 +675,22 @@ bool kvm_apic_match_dest(struct kvm_vcpu *vcpu, struct kvm_lapic *source,
> }
> }
>
> +int kvm_vector_2_index(u32 vector, u32 dest_vcpus,

(The "2" in name is inconsistent, other functions use "to".)

> + const unsigned long *bitmap, u32 bitmap_size)
> +{
> + u32 mod;
> + int i, idx = 0;
> +
> + mod = vector % dest_vcpus;
> +
> + for (i = 0; i <= mod; i++) {
> + idx = find_next_bit(bitmap, bitmap_size, idx) + 1;

I'd remove this "+ 1". Current users don't check for errors and always
do "- 1". The new error value could be 'idx = bitmap_size', with u32 as
return type.

> + BUG_ON(idx > bitmap_size);
> + }
> +
> + return idx;
> +}
> +
> bool kvm_irq_delivery_to_apic_fast(struct kvm *kvm, struct kvm_lapic *src,
> struct kvm_lapic_irq *irq, int *r, unsigned long *dest_map)
> {
> @@ -727,21 +743,51 @@ bool kvm_irq_delivery_to_apic_fast(struct kvm *kvm, struct kvm_lapic *src,
>
> dst = map->logical_map[cid];
>
> - if (kvm_lowest_prio_delivery(irq)) {
> + if (!kvm_lowest_prio_delivery(irq))
> + goto set_irq;
> +
> + if (!kvm_vector_hashing_enabled()) {
> int l = -1;
> for_each_set_bit(i, &bitmap, 16) {
> if (!dst[i])
> continue;
> if (l < 0)
> l = i;
> - else if (kvm_apic_compare_prio(dst[i]->vcpu, dst[l]->vcpu) < 0)
> + else if (kvm_apic_compare_prio(dst[i]->vcpu,
> + dst[l]->vcpu) < 0)
> l = i;
> }
> -
> bitmap = (l >= 0) ? 1 << l : 0;
> + } else {
> + int idx = 0;
> + unsigned int dest_vcpus = 0;

(No need to zero them. Compiler will optimize it, but it increases the
cognitive load on readers.)

> +
> + dest_vcpus = hweight16(bitmap);
> + if (dest_vcpus == 0)
> + goto out;
> +
> + idx = kvm_vector_2_index(irq->vector,
> + dest_vcpus, &bitmap, 16);
> +
> + /*
> + * We may find a hardware disabled LAPIC here, if that
> + * is the case, print out a error message once for each
> + * guest and return.
> + */
> + if (!dst[idx-1] &&
> + (kvm->arch.disabled_lapic_found == 0)) {

('!kvm->arch.disabled_lapic_found' would make it fit on one line.)

> + kvm->arch.disabled_lapic_found = 1;
> + printk(KERN_ERR

KERN_INFO is the maximal applicable level (and the appropriate one).
It's not an error on host side, just a pointer that the guest does
something stupid.

> + "Disabled LAPIC found during irq injection\n");
> + goto out;
> + }
> +
> + bitmap = 0;
> + __set_bit(idx-1, &bitmap);
> }
> }
>
> +set_irq:
> for_each_set_bit(i, &bitmap, 16) {
> if (!dst[i])
> continue;
> diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c
> @@ -123,6 +123,9 @@ module_param(tsc_tolerance_ppm, uint, S_IRUGO | S_IWUSR);
> unsigned int __read_mostly lapic_timer_advance_ns = 0;
> module_param(lapic_timer_advance_ns, uint, S_IRUGO | S_IWUSR);
>
> +bool __read_mostly enable_vector_hashing = 1;
> +module_param(enable_vector_hashing, bool, S_IRUGO);

I think the parameter is well described even without "enable" prefix,
thanks to "bool" type.