Re: First kernel patch (optimization)

From: Alexander Duyck
Date: Tue Sep 15 2015 - 17:57:13 EST


On 09/15/2015 12:52 PM, Eric Curtin wrote:
My first kernel patch, hope I did everything correctly! Instead of calling strlen on every iteration of the for loop, just call it once instead and store in a variable.

Signed-off-by: Eric Curtin <ericcurtin17@xxxxxxxxx>

diff --git a/tools/usb/usbip/src/usbip_detach.c b/tools/usb/usbip/src/usbip_detach.c
index 05c6d15..9db9d21 100644
--- a/tools/usb/usbip/src/usbip_detach.c
+++ b/tools/usb/usbip/src/usbip_detach.c
@@ -47,7 +47,9 @@ static int detach_port(char *port)
uint8_t portnum;
char path[PATH_MAX+1];

- for (unsigned int i = 0; i < strlen(port); i++)
+ unsigned int port_len = strlen(port);
+
+ for (unsigned int i = 0; i < port_len; i++)
if (!isdigit(port[i])) {
err("invalid port %s", port);
return -1;


You should probably run this through scripts/checkpatch.pl as I don't think declaring i inside the loop is consistent with the kernel coding standard. Also you don't want the space between port_len and the declaration of path.

Also you might want to consider just running the loop from port_len down to 0 doing something like:
while (port_len) {
if (!isdigit(port[--port_len])) {
err("invalid port %s", port);
return -1;

The advantage to running the loop backwards is that you have to carry one less variable which means one less register to mess with in the final compiled code.

- Alex

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/