Re: [PATCH -mm 2/3] slab: zap kmem_cache_shrink return value

From: Vladimir Davydov
Date: Mon Jan 26 2015 - 12:04:33 EST


On Mon, Jan 26, 2015 at 09:49:47AM -0600, Christoph Lameter wrote:
> On Mon, 26 Jan 2015, Vladimir Davydov wrote:
>
> > @@ -2400,11 +2400,16 @@ int __kmem_cache_shrink(struct kmem_cache *cachep)
> > return (ret ? 1 : 0);
> > }
> >
> > +void __kmem_cache_shrink(struct kmem_cache *cachep)
> > +{
> > + __cache_shrink(cachep);
> > +}
> > +
>
> Why do we need this wrapper? Rename __cache_shrink to __kmem_cache_shrink
> instead?
>

__cache_shrink() is used not only in __kmem_cache_shrink(), but also in
SLAB's __kmem_cache_shutdown(), where we do need its return value to
check if the cache is empty.

Thanks,
Vladimir
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/