Re: [PATCH v2 1/3] mfd/axp20x: change battery cell name to fuel gauge

From: Sebastian Reichel
Date: Sun Jan 25 2015 - 07:58:01 EST


On Thu, Jan 22, 2015 at 12:52:05PM -0800, Todd Brandt wrote:
> Name changes to the battery cell structure to a
> more generic cell type: fuel gauge.
>
> Signed-off-by: Todd Brandt <todd.e.brandt@xxxxxxxxxxxxxxx>
> ---
> drivers/mfd/axp20x.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> v1: 01/07/14
> v2: 01/22/14
> - replaced the const in axp20x_acpi_match declaration
>
> diff --git a/drivers/mfd/axp20x.c b/drivers/mfd/axp20x.c
> index b1b580a..0acbe52 100644
> --- a/drivers/mfd/axp20x.c
> +++ b/drivers/mfd/axp20x.c
> @@ -87,7 +87,7 @@ static struct resource axp20x_pek_resources[] = {
> },
> };
>
> -static struct resource axp288_battery_resources[] = {
> +static struct resource axp288_fuel_gauge_resources[] = {
> {
> .start = AXP288_IRQ_QWBTU,
> .end = AXP288_IRQ_QWBTU,
> @@ -350,9 +350,9 @@ static struct mfd_cell axp288_cells[] = {
> .resources = axp288_charger_resources,
> },
> {
> - .name = "axp288_battery",
> - .num_resources = ARRAY_SIZE(axp288_battery_resources),
> - .resources = axp288_battery_resources,
> + .name = "axp288_fuel_gauge",
> + .num_resources = ARRAY_SIZE(axp288_fuel_gauge_resources),
> + .resources = axp288_fuel_gauge_resources,
> },
> {
> .name = "axp288_pmic_acpi",

Acked-By: Sebastian Reichel <sre@xxxxxxxxxx>

-- Sebastian

Attachment: signature.asc
Description: Digital signature