Re: [PATCH 09/16] rcu: Remove redundant check for online cpu

From: Pranith Kumar
Date: Wed Jul 23 2014 - 11:45:26 EST


On Wed, Jul 23, 2014 at 11:30 AM, Paul E. McKenney
<paulmck@xxxxxxxxxxxxxxxxxx> wrote:
> On Wed, Jul 23, 2014 at 11:11:45AM -0400, Pranith Kumar wrote:
>> On Wed, Jul 23, 2014 at 10:23 AM, Paul E. McKenney
>> <paulmck@xxxxxxxxxxxxxxxxxx> wrote:
>> > On Wed, Jul 23, 2014 at 10:12:54AM -0400, Pranith Kumar wrote:
>> >> On Wed, Jul 23, 2014 at 9:50 AM, Paul E. McKenney
>> >> <paulmck@xxxxxxxxxxxxxxxxxx> wrote:
>> >> > On Wed, Jul 23, 2014 at 08:59:06AM -0400, Pranith Kumar wrote:
>> >> >> On Wed, Jul 23, 2014 at 8:21 AM, Paul E. McKenney
>> >> >> <paulmck@xxxxxxxxxxxxxxxxxx> wrote:
>> >> >> > On Wed, Jul 23, 2014 at 01:09:46AM -0400, Pranith Kumar wrote:
>> >> >> >> There are two checks for an online CPU if two if() conditions. This commit
>> >> >> >> simplies this by replacing it with only one check for the online CPU.
>> >> >> >>
>> >> >> >> Signed-off-by: Pranith Kumar <bobby.prani@xxxxxxxxx>
>> >> >> >
>> >> >> > I admit that it is very early in the morning my time, but I don't see
>> >> >> > this change as preserving the semantics in all cases. Please recheck
>> >> >> > your changes to the second check.
>> >> >> >
>> >> >> > Thanx, Paul
>> >> >>
>> >> >> I guess you must be thrown off by the complementary checks, the first
>> >> >> check is for cpu_online() and second is for cpu_is_offline(). :)
>> >> >>
>> >> >> Previously, if a cpu is offline, the first condition is false and the
>> >> >> second condition is true, so we return from the second if() condition.
>> >> >> The same semantics are being preserved.
>> >> >
>> >> > Fair enough!
>> >> >
>> >> > Nevertheless, I am not seeing this as a simplification.
>> >>
>> >> I am not sure what you mean here, do you mean that both the checks are
>> >> actually required?
>> >
>> > I mean that the current compound tests each mean something. Pulling out
>> > the offline test adds lines of code and obscures that meaning. This means
>> > that it is easier (for me, anyway) to see why the current code is correct
>> > than it is to see why your suggested change is correct.
>> >
>>
>> That is a valid point. I did not mean to reduce readability of the
>> code. Just trying to avoid the overhead of smp_processor_id().
>>
>> Not sure if you would prefer this, but how about the following?
>
> If you change the "awake" to something like "am_online", I could get
> behind this one.
>

OK! I will submit that in the next series(with the zalloc check).

--
Pranith
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/