Re: [PATCHv2] usb: gadget: serial: replace hardcoded ttyGS with PREFIX

From: Greg Kroah-Hartman
Date: Mon Jun 30 2014 - 10:46:02 EST


On Mon, Jun 30, 2014 at 01:23:27PM +0200, Richard Leitner wrote:
> Hi,
>
> On Mon, 30 Jun 2014 09:08:01 +0000
> David Laight <David.Laight@xxxxxxxxxx> wrote:
>
> > > > From: Of Richard Leitner
> > > > > Replaces all hardcoded ttyGS strings with the PREFIX macro.
> > > > > Due to the fact the strings are spread over different source files the
> > > > > PREFIX definition is moved to u_serial.h
> > > >
> > > > Lots of changes like:
> > > > > - DBG(cdev, "acm ttyGS%d completion, err %d\n",
> > > > > - acm->port_num, req->status);
> > > > > + DBG(cdev, "acm %s%d completion, err %d\n",
> > > > > + PREFIX, acm->port_num, req->status);
> > > >
> > > > I'm not sure this improves the code.
> > >
> > > Maybe you're right, the readability of the code wouldn't be better afterwards,
>
> but as I already mentioned IMHO if there is such a macro it should be used everywhere or nowhere...
>
> >
> > Indeed it will make most attempts to grep for the error message fail.
>
> So your thought is to carve it out completely?
>
> Are there any other opinions/ideas on that?

Use the "proper" debug macros that the kernel provides you (i.e.
dev_dbg() and family) and then you don't need to put the string in there
at all, the kernel will do it automatically for you, in the correct
format, so that all userspace tools can properly track what is going on.

So please remove the horrid DBG() macro entirely.

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/