RE: [PATCH 2/2] i2c: designware-pci: set ideal HCNT, LCNT and SDA hold time value

From: Chew, Chiau Ee
Date: Mon Mar 10 2014 - 07:35:17 EST




> -----Original Message-----
> From: Wolfram Sang [mailto:wsa@xxxxxxxxxxxxx]
> Sent: Sunday, March 09, 2014 5:04 PM
> To: Chew, Chiau Ee
> Cc: Mika Westerberg; linux-i2c@xxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx
> Subject: Re: [PATCH 2/2] i2c: designware-pci: set ideal HCNT, LCNT and SDA
> hold time value
>
> On Fri, Mar 07, 2014 at 10:12:51PM +0800, Chew Chiau Ee wrote:
> > From: Chew, Chiau Ee <chiau.ee.chew@xxxxxxxxx>
> >
> > On Intel BayTrail, there was case whereby the resulting fast mode bus
> > speed becomes slower (~20% slower compared to expected speed) if using
> > the HCNT/LCNT calculated in the core layer. Thus, this patch is added
> > to allow pci glue layer to pass in optimal HCNT/LCNT/SDA hold time
> > values to core layer since the core layer supports cofigurable
> > HCNT/LCNT/SDA hold time values now.
> >
> > Signed-off-by: Chew, Chiau Ee <chiau.ee.chew@xxxxxxxxx>
>
> Can you make use of those instead?
>
> u32 sda_falling_time;
> u32 scl_falling_time;
>
> This is more consistent with using sda_hold_time and lets them have a common
> (and more readable) unit.

Would like to clarify on your statement above. So you are suggesting to change the following
variable name in the code? As in:
"u32 ss_hcnt;" to "u32 ss_scl_rising_time"
"u32 fs_hcnt;" to "u32 fs_scl_rising_time"
"u32 ss_lcnt;" to "u32 ss_scl_falling_time"
"u32 fs_lcnt;" to " u32 fs_scl_falling_time"
"u32 sda_hold;" to "u32 sda_hold_time"

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/