Re: [PATCH v1 7/7] jump_label: use defined macros instead of hard-codingfor better readability

From: Jiang Liu
Date: Wed Sep 25 2013 - 11:47:31 EST


On 09/25/2013 10:53 PM, Steven Rostedt wrote:
> On Wed, 25 Sep 2013 18:44:27 +0800
> Jiang Liu <liuj97@xxxxxxxxx> wrote:
>
>> From: Jiang Liu <jiang.liu@xxxxxxxxxx>
>>
>> Use macro JUMP_LABEL_TRUE_BRANCH instead of hard-coding for better
>> readability.
>>
>> Signed-off-by: Jiang Liu <jiang.liu@xxxxxxxxxx>
>> Cc: Jiang Liu <liuj97@xxxxxxxxx>
>> ---
>> include/linux/jump_label.h | 3 ++-
>> 1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/include/linux/jump_label.h b/include/linux/jump_label.h
>> index a507907..b697fbd 100644
>> --- a/include/linux/jump_label.h
>> +++ b/include/linux/jump_label.h
>> @@ -116,7 +116,8 @@ extern void static_key_slow_dec(struct static_key *key);
>> extern void jump_label_apply_nops(struct module *mod);
>>
>> #define STATIC_KEY_INIT_TRUE ((struct static_key) \
>> - { .enabled = ATOMIC_INIT(1), .entries = (void *)1 })
>> + { .enabled = ATOMIC_INIT(1), \
>> + .entries = (void *)JUMP_LABEL_TRUE_BRANCH })
>> #define STATIC_KEY_INIT_FALSE ((struct static_key) \
>> { .enabled = ATOMIC_INIT(0), .entries = (void *)0 })
>>
>
> Probably should add a comment that there is no
> "JUMP_LABEL_FALSE_BRANCH" or maybe we should add one?
Hi Steven,
How about
JUMP_LABEL_TYPE_MASK/JUMP_LABEL_TRUE_BRANCH/JUMP_LABEL_FALSE_BRANCH
tuple? That should have the best readability.
Thanks!

>
> -- Steve
>
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/