Re: [PATCH] cifs: Rename cERROR and cifserror to cifs_vfs_err

From: Jeff Layton
Date: Wed Mar 13 2013 - 07:52:07 EST


On Wed, 13 Mar 2013 04:36:54 -0700
Joe Perches <joe@xxxxxxxxxxx> wrote:

> On Tue, 2013-03-12 at 15:44 -0700, Joe Perches wrote:
> > The cERROR macro is always used as cERROR(1, and cifserror
> > is just a printk(KERN_ERR "CIFS VFS: ".
> >
> > Make a cifs_vfs_err function that uses the vsprintf %pV
> > extension to avoid duplicating the "CIFS VFS: " prefix.
> >
> > Remove the cERROR macro and use cifs_vfs_err directly.
>
> Perhaps a better idea than this patch is to
> change both the cERROR and cFYI macros to
> a new use of cifs_dbg(type, fmt, ...)
>
> cERROR(set, fmt, ...) -> cifs_dbg(VFS, fmt, ...)
> cFYI(set, fmt, ...) -> cifs_dbg(FYI, fmt, ...)
>
> This conversion would mark both these macros
> as debug stataments as they are only enabled
> with CONFIG_CIFS_DEBUG.
>
> Also CONFIG_CIFS_DEBUG2 use of DBG could also
> be integrated with the same style.
>
> cFYI(DBG2, fmt, ...) -> cifs_dbg(NOISY, fmt, ...)
>
> The reduced object size would still apply.
>
> This would also enable an easier conversion to
> dynamic debugging of these debug macros.
>
> I'd prefer to move the newline from the macro
> to the format as that is more consistent with
> the rest of the kernel.
>
> Thoughts?
>

I like this change overall, but the size of the patch is pretty
daunting. If you could change the code that underlies cERROR() and
cFYI() without needing to touch all of their call sites, it might be
a simpler initial step.

OTOH, I would also prefer to move the newline into the format and
that's impossible without touching most of these call sites.

--
Jeff Layton <jlayton@xxxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/