Re: [PATCH -tip ] [BUGFIX] kprobes: Move hash_64() into .text.kprobesection

From: Ingo Molnar
Date: Tue Mar 12 2013 - 04:21:23 EST



* Masami Hiramatsu <masami.hiramatsu.pt@xxxxxxxxxxx> wrote:

> @@ -31,7 +32,7 @@
> #error Wordsize not 32 or 64
> #endif
>
> -static inline u64 hash_64(u64 val, unsigned int bits)
> +static __kprobes inline u64 hash_64(u64 val, unsigned int bits)
> {
> u64 hash = val;

We should also, really, really fix the '__kprobes' misnomer and switch to
the '__noprobe' pattern or so. The naming does not make it obvious at all
that what we do here is to turn _off_ kprobing of select functions...

The only complication is that __kprobes is now present in 600+ places,
which will create merge conflicts. If you remind me during the next merge
window I can generate the rename on the spot and send it to Linus without
anyone having to carry the patch for too long.

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/