Re: [PATCH] Doc: percpu_counter doc code for better readability

From: Tejun Heo
Date: Mon Feb 04 2013 - 16:50:04 EST


On Tue, Jan 29, 2013 at 09:31:56AM +0100, Jesper Dangaard Brouer wrote:
> Help people reading the percpu_counter code, to notice the ifdef
> else statement that seperates CONFIG_SMP.
>
> Signed-off-by: Jesper Dangaard Brouer <brouer@xxxxxxxxxx>
> ---
>
> include/linux/percpu_counter.h | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/include/linux/percpu_counter.h b/include/linux/percpu_counter.h
> index b9df9ed..eded1aa 100644
> --- a/include/linux/percpu_counter.h
> +++ b/include/linux/percpu_counter.h
> @@ -83,7 +83,7 @@ static inline int percpu_counter_initialized(struct percpu_counter *fbc)
> return (fbc->counters != NULL);
> }
>
> -#else
> +#else /* No CONFIG_SMP */

"#else /* !CONFIG_SMP */" would be more conventional. Can you please
change that and repost it w/ my Acked-by and [TRIVIAL] tag added and
Jiri Kosina <trivial@xxxxxxxxxx> cc'd?

Thanks.

--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/